Get Text and Screen Scraping not working on Powershell screen

So I am running SSH commands in Powershell. I initially tried to do this using Invoke Powershell activity but gave up cos I was having trouble doing the copy to clipboard/right-click combo to paste the password when prompted. I decided to use the UI activity by opening the PS and TypeInto to put in the commands. All these fine.

Problem arises when I try to get the text on the PS screen into a text file. I have tried:

  • Get Text - does not detect the UI element at all (I used F4 to change the element to no avail)
  • Get OCR Text - using the UiPath Screen OCR resulted in APIKey error. Using the Tesseract OCR seems to read the element but returns a bunch of junk that makes no sense).

Any idea how I can get the text from this PS screen into a text file will be much appreciated. Thanks in advance!


Can you try classic GetVisibleText activity?

In my environment, it works.


1 Like

Worked! Thank you so much for saving my evening - again :).

1 Like

FYI, we can also get the text using Modern GetText with manual settings. Can you try the following steps?

First, put UseApplication activity and indicate window of PowerShell. Then, get content of Selector property.

Next. put GetText activity and set the following items manually. Strict selector is from the above selector.

Finally, we can get the content.



This also worked great, thanks!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.