Get Text and Click activities doesn't work on pop-ups

Hi again,

While doing the Generate Yearly Report assignment, every time a pop-up opens (when uploading the yearly report, for example), the selectors apparently can’t find it.

When configuring the selector, it takes too long to find the text/button you want. Then, even if it is getting the text correctly, when running the project it gets stuck there (not showing exceptions, just stuck in the Get Text activity).

I’ve tried with multiple browsers, I’ve disabled the Computer Vision when configuring the selector (which speeds the selection quite a bit), but it keeps getting stuck.

I’ve also updated all the packages.



Hi @JavRip,

Have you tried with Simulate input method in Properties,


If not working, try other input methods also.



To resolve issues with selectors not finding pop-up elements in the Generate Yearly Report assignment, use the UiPath “Attach Browser” activity and make sure to indicate the browser or application window containing the pop-up, which often improves selector reliability.

1 Like

You shouldn’t be using Computer Vision if it’s just a normal web page.

Anyway, try a Use Application/Browser to attach to the popup, with the click/type activities inside it.

Attach Browser is the old classic activity. Aren’t you working in modern yet? You should be.

I’m working with modern all the time, but in this particular sequence I finally had to use the classic activities.

I was having the same issue over and over with the modern Use app/browser, click and get text activities once the pop-up came up. Keep in mind that in both Edge and Chrome, the pop-ups are not the classics that opens in new windows, they’re embedded in the browser, so I can’t select them independently in the Use app/browser activity.

The classic activities worked fine.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.