Get Row Item not always there

My ‘Get Row Item’ works great when the column header is found, however, if missing, I get error: “Column doesn’t belong to the table”. I tried an if statement, but that isn’t working either. I want it to skip that header, if it can’t find it. Any suggestions? Thanks!

Have you tried using column index’s instead of column names?

Hi @DMRaymond

you can share your xaml to easily address the issue.

cheers :smiley:

Happy learning :smiley:

Hi @DMRaymond

Surround Get Row Item with try catch activity :wink:

JothyPrasanth M

Seems to be your input is having dynamic column name. In this case you can try below:
1-Before taking input, work with team to make the input header standard
2- Refer columns by Index
3- Few application create unknow spaces on Header, in those cases,create a reusable component which will format your header

Are you getting the table or you already have data in excel?

If you need to get dataTable first from same website, write the datatable in CVS first and see if you have data in the file. If dont have any data you must scrap the table again and see if the filds you are trying to get to the table are dinamyc.