Get outlook mail messages : The specified folder does not exist

Can anyone share me the solution as I am facing the same problem!!

I have the same issue

am getting these error ?

Change the Mailfolder as Inbox in the properties and give a try

What Next ? Its Not Working ?

1 Like

Remove the mailid from Account property.

3 Likes

https://forum.uipath.com/t/create-mail-folder-in-outlook/19479/10?u=sarigam

Please refer to the link for more info.

Hi!

I’m Kyung-hoon

I succeeded after changing the value of mailfolder in the property panel.

Thanks a lot!

Hi there,

I tried using the workflow but didnt have any success.

Would you know what seems to be missing?

Or is there any sort of set-up that needs to be done on my machine?

Thanks!

Hi Experts,

I am also facing the same issue " Get outlook mail messages : The specified folder does not exist".
I have Outlook2016 in my machine.

Even with the default downloaded assignment in foundation tutorial.

  1. Tried with and without account name.
  2. Tried suppling different forlder names

But the error remains the same. Is there any outlook setting that has to be there for it to work?

Hi @parshantgarg,

Could you upload your workflow…

Thanks for quick reply , PFB the workflow screen shot…

@parshantgarg Try putting “Inbox”.ToString and see if that works. Let me know.

Hi @Haich

Still the same error:

Main has thrown an exception

Message: The specified folder does not exist

Source: Get outlook mail messages

Exception Type: ArgumentException

System.ArgumentException: The specified folder does not exist
at UiPath.Mail.Activities.GetMailActivity.EndExecute(AsyncCodeActivityContext context, IAsyncResult result)
at System.Activities.AsyncCodeActivity.System.Activities.IAsyncCodeActivity.FinishExecution(AsyncCodeActivityContext context, IAsyncResult result)
at System.Activities.AsyncCodeActivity.CompleteAsyncCodeActivityData.CompleteAsyncCodeActivityWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)

@parshantgarg What version of outlook have you got installled?

Hi All,

Same issue ROBO is working fine from last 4-5 months all of sudden issue occurred
Addin few people usually provide solutions
@badita @ClaytonM @aksh1yadav

Hi,

i am getting the same issues i have used this activity before and many time i have put Inbox only but its not working can any one please let me know what should be the issue under MailFolder i have Given “Inbox” and under account i have given nothing

Hi,

  1. Close the Outlook
  2. Open it using “Run as Administrator”
  3. Execute the program.

Let me know if it works for you. I was facing the same issue and it gave me the way to read outlook.

Regards
Vivek S.

1 Like

Try this…

  1. Close the Outlook
  2. Open it using “Run as Administrator”
  3. Execute the program.
2 Likes

inbox not inobx

1 Like