Get Full Text Error - Error HRESULT E_FAIL has been returned from a call to a COM compenent

Hi all,

I had go through the forum about the above error. I had tried to do “Delay” before Get Full Text, Install .NET 4.7.2. Im do the scraping for PDF. Any idea?Thanks.

Uninstall PDF Activities from Manage Extensions.
Install PDF Activities again. Restart UIPath Studio. Try again.

From what I’ve noticed, this error usually has to do with the parent selector (the first line of the selector that indicates the application container).

I see this sometimes occur with Internet Explorer on sites the return <html /> as the first line instead of <app='iexplorer.exe title='Page Name' /> or something like that. You can see this while using UiExplorer - also, Chrome reacts differently to the webpage or usually works when this happens.

However, you are using a PDF container, so I guess are you trying to scrape the text from a web frame or are you opening a PDF file with Adobe? Also, it would be helpful if you provided the selector of the text you are trying to scrape from UiExplorer.exe, which may or may not identify if there is an issue with it. Note: also try the full selector outside of an Attach Window/Browser to identify if the issue is with the Attach Window/Browser.



any solution for this? same error occurs for me

It was working fine , but now suddenly this error