Get File List from SalesForce Extension Package not registering it is inside SalesForce Application Scope

Help please. I have SalesForce Application Scope set up correctly. I know because I am able to run execute SOQL and get output. However, I want to get a list of files in a library. I was thinking the Get File List activity from the SF Extension package might work, but it is not registering that it is inside of a SalesForce Application Scope. I have tried the Get File List activity from both UiPathTeam.Salesforce.extenstionPackage.Activities v and from UiPathTeam.Salesforce.Lightning_Platform.Activities v and both are behaving the same way. The Get File List search command is the same thing that executes successfully in Execute SOQL below. I know I probably have the wrong table there, but it should at least complete, even if it doesn’t get exactly what I need.

Can’t share the xaml due to security, but screen shot below.

Can someone please suggest a better way to get the letters within a library in salesforce, or help make the get file list function work?


I also tried using Download All Files From Case and I am getting the same error “Activity is only valid inside SalesForce Application Scope” even though it IS inside a SF Application Scope.

Hello Warek,
From what I see in your image the main issue is that you USE Salesforce Application Scope from
Salesforce Activities (Official UiPath) and Get File List is from my activity Salesforce Extention Package.
So you need to use Salesforce Application Scope from Salesforce Extention Package.
Another option for you is to use the RAW REST API commands like in these videos:


Thanks Cristian, that solved one issue, I can add the Download All Files From Case activity in the new SF application scope from the extension package, but it is now causing another issue. For some reason, the SalesForce Application Scope from the extension package won’t allow me to use variables of secure string type for the authentication values. I am using Orchestrator to store the SF credentials. When I use the Get Credential activities, the password values now error, saying “compiler error(s) encountered processing expression “Token”
Value of type ‘String’ cannot be converted to ‘System.Security.SecureString’”. I was able to code around it by using an assign function (string password =new System.Net.NetworkCredential(string.Empty,securePassword).Password) to translate the secure strings from orchestrator to regular string variables, but I’m sure secure string would be preferred from security standpoint. Why can’t the SalesForce Application Scope from the extension package accept SecureString variables for token, password, etc?- thanks, Katie