Get Attribute Activity not Returning the Href

Hi all,

I’m trying to get the first URL for the 1st Google search result using the get attribute activity and selected href as my target attribute.

My selector is working fine and is able to highlight the 1st search result. However, the get attribute activity is returning a blank value.

Has anyone encountered this scenario? Should I be selecting a different attribute instead of href for Google search results?

image

Based on the message box below, the activity was not able to fetch anything.

image

I dont see an ‘href’ attribute. I would recommend checking items like this by using UI Explorer, then use the indicate element button, then check in the property explorer to see all the attributes available for that specific element.

You could try to grab the element above that shows the full url and grab the innertext/outertext instead?

I tried the innertext/outertext, I was not able to get the actual URL. I also tried to set it to “url” but it’s giving me the incorrect link. I’ll just use the get text activity to fetch the website on the above hyperlink then split the text using “>”.

Thanks for the suggestion

Use the innertext/outertext of the element ABOVE the one you were selecting. It’s a different element, not the one you have highlighted with the red box