Get Access token with the new Cloud Orchestrator

I am trying to get access token but i am getting error in it . I request all scholars please help me with correct input parameter for given activity .

I have an idea from where to get client Id but rest is somewhat confusing .I have also referred this link https://docs.uipath.com/orchestrator/reference/consuming-cloud-api but input parameters are different .Where to fetch value of scope and grant type from image .

@loginerror , @harsh497 guys need your help .

1 Like

Hi @HimanshuSonawane

Where does this activity Post come from?

You might want to use the HTTP Request activity of the UiPath.Web.Activities activity package to send this authentication request.

1 Like

Hi @loginerror

I am creating an Library and in that when we use New Services and insert our orchestrator Swagger URL then automatically all the activities get inherited in our activity panel .We have all the activities that our API supports . I am just not able to pass parameters of it .

On swagger also same parameters are required as attached below

1 Like

Judging by this:

I would expect you only have to paste the request in the accessTokenRequest field and that’s it (that’s for Swagger).

For your library, you should simply pass the json here:
image

1 Like

Hi @loginerror
I have tried above solution in swagger itself . but still no success getting below error for Grant Type

image

The arguments are also not same so i am little bit confuse now . Please i have look if am using correct link for swagger api or not ?

  1. Go to https://cloud.uipath.com/portal_/cloudrpa
  2. Go to Services tab. Here you have your tenant.
  3. Click on the tenant name, so it will route you to your orchestrator.
  4. The address you see now is exactly your (cloud portal)/(tenant name). So you need only to add /swagger/ui/index to it, and done

https://cloud.uipath.com/(cloud portal)/(Orchestrator Tenant Name)/swagger/ui/index

Just to be sure, could you test once in Postman. I checked and it worked for me without an issue.

It could be that there is something we should fix on Swagger.

I’m having the same issue, can you let me know how you resolved this please?