Generate-Yearly-Report-Performer

Hello,

When I run the robot (main), the IE doesn’t open and I get this error.


And when I run only the process.xaml I get this error.

Please help.
Thank you in advance

Hello @Maryem_Karoui,

1st Issue:

  • Based on the issue description and screenshot, I’m guessing you failed to indicate/add in the config file the path/directory where the robot will download & locate the invoice reports. You’re probably using a delete & create directory activities before the Invoke InitAllApplications workflow which is why you’re receiving this error before opening IE.

    • Failing to indicate this in the config file will result in the dictionary error you’re receiving and generate a system failure.
  • A system failure will direct the ReFramework to Close the application, meaning that it will go to the “End Process” transition which contains the “CloseAllApplication” workflow.

  • Now, since IE wasn’t opened the robot won’t be able to locate the necessary selectors needed for the CloseAllApplication workflow.

    • Basically you’re using an attach browser to close IE and the robot can’t find the selector ACME Sytem - * since it was never opened.

2nd Issue:

  • You’re receiving that error since you ran the robot from the Process.xaml without going through the GetTransactionData state.
  • Remember that the robot will be getting the values of the Transaction Items from that state (specifically the Get Transaction Data workflow) and since you bypassed the GTD state the TransactionItem needed for the in_TransactionItem argument has no value, as such you’re receiving the “Object not referenced” error.

I’m guessing you ran the robot from the Process.xaml because you were receiving the directory error from Main. My recommendation would be to indicate the download path in the config file so that you won’t get the dictionary error and see how the rest of the framework runs.

Hopefully it solves your issues, if not then feel free to reply back so that we may assist you further.

Stay safe & healthy! :vulcan_salute: