Generate Yearly Report - One remaining issue - Occasionally unable to locate Save box on Monthly Report page

I have a fully working Level 3 Assignment 2 workflow with one problem, which I have tried everything on suggested in the past in the Forum for this issue, so giving it one more go. The issue is that following the first yearly report upload, I am unable to locate the Save box on the message box at the bottom of the page. I have tried a series of solutions proposed in the Forum: key sequences, attaching the window etc… I am unable to pick up this exception. If anyone has a bullet proof solution to what appears to be a common issue, please let me know your solutions!

I also experience very slow performance at a couple of points in the workflow following the first cycle of annual report generation. Based on the timings of the trace messages it appears to be a delay of exactly 1 or 2 minutes, so I assume a timer somewhere, but very unclear where this is. Based on the trace messages it looks like it may be running in the middleware somewhere. Again anyone who has solved this problem let me know. The WaitForReady property is already set to None…with absolutely no impact.

All help gratefully received!

…that should say the Save box at the bottom of the Monthly report page.

we have tons of help on this, please take a look at those in link bellow:

Thanks. I think I have read most of them already, but will work through the list.

I have tried all the various options to get the selector recognised when there is an occasional problem, but still have the problem, which consistently appears for the first time after the completion of the first vendor annual report upload and starting with January of the next TaxID. There is a very long delay before the second report build process starts (I don’t know why, but that is another issue) which may be the reason there is an issue as it runs perfectly well for the first iteration. Although the selector is not picked up, it hasn’t changed. When I revalidate the selector the xml fragment it generates is identical to what it was when it was showing as not valid. I have copied them out and pasted them side by side and done a character by character comparison. I can only assume for some reason the robot is disconnected from the active page, so wouldn’t be able to find any selector. I have tried Attach Browser and Attach Window, but this does not make a difference. Are there any other diagnostics I can run? Is it possible to test whether the page is not attached?

see this one for the slow part: