Generate Yearly Report Assignment - Unable to select report file

Hi, I have an issue trying to select the report file button to update the yearly report. I tried using the click activity inside an attach window/attach browser activity but it still does not work. Running the project in debug mode shows that there is no issue in the selector as it highlights the correct button. The selector I am using is this:

I also tried setting the click activity to double click and toggling simulate click which still does not work. When I use the "run from this activity" the click button works but doesn't when I run from beginning of the project. Any advice?

Selector used:
image

@Petrifly Can you show us the Selector in UiExplorer with it being validated?

Hi @supermanPunch,

and here it is being highlighted:

@Petrifly Can you Include aaname Property and Show the Selector.

@supermanPunch


It is validated

@Petrifly Change the aaname to ‘*Select Report File*’ and Check if it’s working.

1 Like

@supermanPunch sadly it still does not work. I don’t think its a selector issue as the bot can properly identify the button. It just won’t click it.

@Petrifly Have you set wait for Ready Property to COMPLETE and Simulate Click True?

@supermanPunch Yes

Right now I can get it to work but I must use a click image activity rather than the regular click activity. :pensive: