Generate Yearly Report Assignment 2 - Activity Timeout Exceeded

When I run the framework to send data that was scraped to the Queue, it stops and throws an error in the Process State. On Element Appears ‘Page Number’ Activity Timeout Exceeded.

Here’s my zipped workflow.
GenerateYearlyReport.zip (512.8 KB)

Here’s my updated workflow.
GenerateYearlyReport.zip (512.9 KB)

After following the instructions, I could not get system one to navigate through the pages on the website. Any help would be appreciated.

1 Like

Make sure your on element activity is within the attach browser scope

1 Like

Another tip I can suggest you do instead of manually typing a selector is to click edit selector -> right click on the field you wish to be dynamic and choose a argument/variable. Like this:
image

1 Like

Thank you @Petrifly. The problem that I’m having seems to be that my selector will not validate, I have restarted Studio and tried different selectors and using different tags, but nothing seems to work. I also put the on element activity inside the attach browser scope.

Is there a reason that a selector will not validate?

Currently, your in_transaction has no value so the selector will always fail. You can set some default values for your arguments/variables to test the current process.

1 Like

@Petrifly I set default variables, and it would work to get into the On Element Appears activity, but no matter what I do, it times out when it tries to exit the Activity. It won’t continue onto the next transaction.

When I run the Process the in_Transaction Argument has the TransactionItem as the default value, and it’s set to 1.

After the process leaves the On Element Exists, it has the value of “1”. but when I step through it freezes and times out.

Am I completely missing something? It seems like it should work.

I found the Solution. If this ever happens to anybody, the fix that I’ve found for the issue is to go into the Properties panel of the On Element Appears Activity and set the RepeatForever property to False

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.