Generate Yearly - Dispatcher - No more transaction data

Please assist. I have gone over and over this and the walkthrough, as well as, checked the forums for questions like this.

I’m not getting an error, but when I run it, I see “Process finished due to no more transaction data.”

I added a write line to pinpoint the path that the Get Transaction Data is taking which you can see in the attached picture.

I’ve tried printing the out_TransactionItem but it’s showing as empty which makes me think that my variables and arguments may not be correct, but I don’t see the break or anywhere in the instructions where the TransactionItem gets assigned. (516.7 KB)

Hello @rpa3po

To navigate to pagination you need to attach browser first and check for Element exist of next page button. Please check attached my files for your reference.

SaiProcess.xaml (8.8 KB)
GetTransactionData.xaml (9.8 KB)


Thanks, I wasn’t able to open the workflows in the files but I got what you were saying about having that piece go first!

I update that and now that part is working! :smiley: Thanks!

This actually helped me with my second issue. Looks like I need to get more familiar with where these are nested.


Great. You are welcome. FYI, you can directly open the .xaml file. You need to copy this file into project folder in other place where same filename doesn’t exits. From UiPath Studio you can open the program.


1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.