Gecko Webdriver not working in Uipath

Hi All,

I am trying to run ‘open browser’ activity on a VM using communication method as ‘Web driver’ but it is failing everytime with error “Open Browser: The Web driver executable is not compatible with the Browser version. Please download the appropriate executable”.
I am using Firefox v78.11.0 and gecko driver v0.29.1 and also i have tried multiple gecko driver and firefox browser versions but nothing really helped.
Also, gecko driver is deployed after following all the standard steps provided in Uipath Documentation.
Can anyone help.

Hello @agromil16!

It seems that you have trouble getting an answer to your question in the first 24 hours.
Let us give you a few hints and helpful links.

First, make sure you browsed through our Forum FAQ Beginner’s Guide. It will teach you what should be included in your topic.

You can check out some of our resources directly, see below:

  1. Always search first. It is the best way to quickly find your answer. Check out the image icon for that.
    Clicking the options button will let you set more specific topic search filters, i.e. only the ones with a solution.

  2. Topic that contains most common solutions with example project files can be found here.

  3. Read our official documentation where you can find a lot of information and instructions about each of our products:

  4. Watch the videos on our official YouTube channel for more visual tutorials.

  5. Meet us and our users on our Community Slack and ask your question there.

Hopefully this will let you easily find the solution/information you need. Once you have it, we would be happy if you could share your findings here and mark it as a solution. This will help other users find it in the future.

Thank you for helping us build our UiPath Community!

Cheers from your friendly

Found the solution, webdriver stopped working due to VM Proxy settings which was blocking localhost. After adding NO_PROXY environment variable with all the domains you want to bypass, the issue got fixed

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.