Function key takes action in GUI but not by workflow (Terminal)

Using Terminal activities and doing fine, works great!
But suddenly, the Terminal goes in a “blank/black” state.
This is not related to the automation, this also happens in real life when manager types manually.

In GUI this resolves by pressing F3 - and then the terminal is back on track.

I am using FlowDecision activity to check if the pages are ready to receive information and commands. Works great.

The Get Text at Position activity usually works well when checking if the field contains spaces (empty).

But when this page/window/state turns up (or maybe “out-of-state”), I can’t seem to get in contact with it using the workflow. How can I check if this state is up, and then press F3 and get on with the process?
(If I manually activate the terminal window and presses F3, it works, and the flow carries on.)

strVar = " "
strVar = “”
strVar = Nothing

Thankful for any ideas! :v:


checking this can be done with:
isNothing(yourStringVar) OrElse String.IsNullOrEmpty(yourStringVar)

Hello, @ppr !
Thanks for you suggestion. I tried it out. Still no luck, it does not trigger the control key.