Flow not working properly since converting from windows legacy

Had a message popped up on UIPath recently which said:

“The windows legacy comptaibility will be discontinued in the next enterprise release. We recommend using windows or cross platform when developing new projects. Convert to Windows”

So I converted to Windows and whilst the flow has zero errors, it no longer interfaces with a website like it used to i.e. inputting a value.

If I go into that particular activity, the link is not broken and it still recognises it, but it doesen’t actually work when I run the flow.

There is another Flow I have which I also converted to Windows and similarly, this inputs a value into a site. This still works, albiet running slower than it did before

Hi @steve1977beyond

Could you please provide a few more details? For example, does the issue still occur if you update your UIAutomation package to the latest version (unless it’s already happened as part of the conversion, of course).

Some more details about the selectors would be appreciated as well.

Thought I replied to this so apologies for the delay.

Essentially at it’s core it does the following:

  1. Reads from an Excel file
  2. Copies info to a Data Table
  3. Within Open Browser, it does a ‘For Each Row in Data Table’
  4. goes through each reference in the data table
  5. Typing in each ref into a website

Now I have ascertained that the information is indeed being copied to a Data Table, but when it comes to writing it into the website, it just hangs. Nothing happens.

Another flow, using a previous version of UIPath that interacts with the same website, works with no problem at all.

On both versions (the one which is working and also on the one which isn’t working). The versions are identical
Capture

The only difference is that the one which is not working has been converted to ‘Windows’ as per this message box:
Capture2

I also encountered quite a number of errors after converting my workflows from WIndows-Legacy to Windows. Each of the workflow are having different type of error.

  1. Error (Could not find file C:.…{x:Null}) the moment when i clicked on Debug button.

  2. When the converted project files was copied to another PC with UiPath Studio version 2020.10.4, encountered access denied error when trying to open the project file. I tried to open UiPath Studio as “Run as Administrator” and open the project file, then the project can be open successfully. However, when i tried to debug… it gives me similar error of access denied or file not found error. This error doesnt happen if I tried to open the same project file under Windows-Legacy format.

  3. Argument that I didn’t use, UiPath Studio will complaint and ask me to removed them during debug. After remove the argument from the workflow, I need to literally open all the .XAML file that has Invoke Workflow File activity to that workflow for refresh, else the same error will keep on repeating.

Hi @Jim_L

Would you mind privately sharing the legacy project that is having this issue?

We would like to have a look and see if something can be improved.

Hi @loginerror,

Thanks for your msg.
Kindly advice how do i share my project privately to you.

Thank you.

Hello @Jim_L

After converting the project from Windows legacy to Windows, did you try updating all the dependency packages? If not, please give it a try and update it here.

Thanks

Hi @Rahul_Unnikrishnan ,

Yes, I’ve updated all the packages.

You can click on my profile and choose to message me.

A video of your issues would be nice as well.

Was a solution found? I am also experiencing similar issues when converting from Legacy to Windows.