Flow designed in community version doesn't execute in UIRobot Trial version on a VM

robot

#1

Scenario: We’re moving towards a licensed version of UIPath. To fully get this tested, I moved a workflow designed in CE to the trial IDE (I’m getting the licenses shortly, it’s a commercial matter out of my hands) and published it through that IDE. When executed through de IDE, Workflow does everything it’s supposed to, but when launching UIRobot and trying to execute it from there, it comes back with the following error:

11:55:50.2648 Error {“message”:“Cannot create unknown type ‘{http://schemas.microsoft.com/netfx/2009/xaml/activities}Variable({http://schemas.uipath.com/workflow/activities}WorkbookApplication)’.”,“level”:“Error”,“logType”:“User”,“timeStamp”:“2018-07-22T11:55:50.2639125-03:00”,“fingerprint”:“ed7b0813-96b3-4158-9c66-07238caeacad”,“windowsIdentity”:"",“machineName”:“RPA-01”,“processName”:“OrdenamientoServiciosVTV”,“processVersion”:“1.0.6777.19912”,“fileName”:“Main”,“jobId”:“e90cc13e-8634-4eb7-b496-25e55f3a6a0f”,“robotName”:""}
11:55:50.2648 Error {“message”:“UiPath.Core.Activities”,“level”:“Error”,“logType”:“User”,“timeStamp”:“2018-07-22T11:55:50.2775779-03:00”,“fingerprint”:“842640e5-60f6-42c5-a28e-8a69fa78d61c”,“windowsIdentity”:"",“machineName”:“RPA-01”,“processName”:“OrdenamientoServiciosVTV”,“processVersion”:“1.0.6777.19912”,“fileName”:“Main”,“jobId”:“e90cc13e-8634-4eb7-b496-25e55f3a6a0f”,“robotName”:""}

11:55:53.5295 Error {“message”:“Log message : Object reference not set to an instance of an object.”,“level”:“Error”,“logType”:“Default”,“timeStamp”:“2018-07-22T11:55:53.5383244-03:00”,“fingerprint”:“05089191-b47f-48d7-b397-a35c2c9adeb5”,“windowsIdentity”:"",“machineName”:“RPA-01”,“processName”:“OrdenamientoServiciosVTV”,“processVersion”:“1.0.6777.19912”,“fileName”:“Main”,“jobId”:“e90cc13e-8634-4eb7-b496-25e55f3a6a0f”,“robotName”:""}
11:55:53.5451 Info {“message”:“OrdenamientoServiciosVTV execution ended”,“level”:“Information”,“logType”:“Default”,“timeStamp”:“2018-07-22T11:55:53.5422328-03:00”,“fingerprint”:“048f8f83-5beb-4047-b125-bea688f96004”,“windowsIdentity”:"",“machineName”:“RPA-01”,“processName”:“OrdenamientoServiciosVTV”,“processVersion”:“1.0.6777.19912”,“fileName”:“Main”,“jobId”:“e90cc13e-8634-4eb7-b496-25e55f3a6a0f”,“robotName”:"",“totalExecutionTimeInSeconds”:9,“totalExecutionTime”:“00:00:09”}

Steps to reproduce: can attach workflow on demand (it’s rather complex)

Current Behavior: flow crashes after a while with the mentioned error message

Expected Behavior: execute just as well as when executed through Studio

Studio/Robot/Orchestrator Version: 2018.2.3 Enterprise Edition / UIRobot 2018.2.3

Last stable behavior: never
Last stable version: n/a
OS Version: Windows 10 Enterprise
Others if Relevant: (workflow, logs, .net version, service pack, etc): Runs on a VM (I’ve no idea what Stack is used)


#2

Hello, let us know if you have installed all the packages in the IDE version (use ctrl + p)

Edit : check if UiPath.Core.Activities are installed.


#3

UIPath.Core.Activities is installed, version 18.2.6745.15248.
Additionally, this flow uses only sanctioned packages which I carried over to the Trial versions (meaning there’s no Beta or Community package used)

Cheers
Stratum


#4

Are you running this workflow from robot or studio?
Your error says you are trying to run a workflow having an older version of the excel package, older than the one used to develop it.


#5

Reading is a good gift, thatnk you tatu… hey let us know if you can solve it.

because I am confused on the part of it launch but when the uirobot launch, I guess the uirobot launches before the actual process starts… sorry 3 am in here… so I guess you can’t run it or you can?

oh, I see that you run it from cmd ? something like that… please explain… regards… sorry once again…


#6

Wow, I’ve no idea where you see the package version in the Error, but glad you spotted that. So, to clarify, I run a CE version on my local machine, which I’ve been using to see where I can take things RPA-wise.
The company finally saw the light and is going to get licenses, but asked me to make it work on a VM. In order to get this done and tested properly, I installed the UiPath Studio and Robot trial version (freshly downloaded, so it should be the latest version available on the site). I installed the available packages, copied a proyect to said VM, adjusted it to take out all activities that need Beta or otherwise packages (btw, Callout is a real drag, AttendedRobotStatus is golden).

Running the flow in Studio (Trial version), works like expected, but as soon as I publish it and try to run it from UiRobot (I launch it separately to have it in the Taskbar), this error shows up.

If the package in Trial version is older, my question is, how do I get the newer package? Update is greyed in the package manager. Maybe there’s a file or something I could copy from my CE version? Is that advisable (cuz it sure doesn’t feel that way)?

Anyways, TLDR, With Studio it works, with Robot it doesn’t, package is the one that came with Trial version. But I don’t want to have to launch Studio to run the bots, that’s kinda defeating the whole purpose.

Thanks for the help
Cheers
Stratum


#7

Update:
both have now 2.4.6666.26225 UIPath.Excel.Activities. Still the same result. Does UiRobot use different packages? (forgive my ignorance, but I genuinely don’t know)

Cheers
Stratum


#8

Both are 2018.2.3?


#9

Yes, they are. Unless it says 2018.2.3 but is really some other version, which wouldn’t make much sense :frowning_face:

Cheers
Stratum


#10

Hi,
Robot and Studio use different sources when trying to download any activity that it uses as dependency.

Studio configuration for dependencies is
%appdata%\nuget\NuGet.Config

Robot configuration file for its sources is
C:\Program Files (x86)\UiPath\Studio\NuGet.Config

Open these 2 files and make sure they have the same entries (especially check if there are any missing for the robot one).
If anything is missing, add it, restart the robot (tray or service) and try again.

If this does not work go to Start > Event Viewer > Application , clear the logs, try to start the job again from robot tray, and see if there are any errors logged.
If yes, export it and upload the log containing the errors so that we can take a look.


#11

Hey Andrei,
This was the key to the problem. They were effectively pointing to different sources, the Robot in parcticular to an invalid source, which caused the whole problem apparently. After changing the config, it worked smoothly.

Thank you very very much!

Cheers
Stratum