First Automation in UiPath Studio - Click command not working as expected

I’m trying to create a simple automation that changes my PC’s lighting scheme across multiple programs in a single robot. My hardware manufacturers all use separate lighting applications that do not talk to one another, and I thought this would be a cool first project.

The robot opens the first application, but the click function/command doesn’t expand the list as it does in the application with a physical click. There is no actual ‘button’ to click, and maybe that’s the issue here.

I have adjusted the delay before click, but that didn’t work, either.

I’ve attached a screenshot below for clarification.

1 Like

Welcome to uipath community
Did we try with send hot key activity with key as tab
Like use n number of such activity with no element chosen for selector until it reaches the field Or button we want

Once after reaching the field or button use again send hot key with key either as enter or down key so that it will list down the options

Cheers @smart_automation

Hey smart_automation. Have you got ‘simulate click’ or ‘send windows messages’ enabled?

You could also use click image if nothing works for you…

Thanks for the warm welcome—and the suggestions! Palaniyappan - thanks, I did try using the send hot key using ‘tab’ and then ‘enter’, but for whatever reason the element within the application is unable to be targeted/selected with the tab key.

@pduffy - I tried both set to false, then each to true separately, neither worked!

@bcorrea - This worked! Though, it is noticeably slower than using a click. It’s fine for what I’m trying to achieve.

Funny thing is, some elements/buttons in the application DO work and are able to be targeted using the simple click command. It seems like the lazyload/ajax style accordion dropdown just doesn’t want to play nicely.

Thanks for everyone’s help!

1 Like

Hello again :slight_smile: Do you get any error message involving trying to access a “failed COM component”?