First Automation - CurrencyConverter


I have a couple of questions regarding the CurrencyConverter project:

1.- When using the Get Text Actions to retrieve the currency, rather than marking the anchors and targets in blue and/or green, they are marked in red and the confirmation box says something about inconsistency (sorry, I don’t remember the exact message and I did this a couple of days ago). When I run the bot however, it executes perfectly and retrieves the values correctly, when I was expecting an error to actually occur. Could you please let me know why the tool reports an error (and I can do to fix it) and why it didn’t fail? I am trying to show you the image from StudioX, but it doesn’t seem possible…

2.- When the Excel file gets created, it was named YYYY0506.xls, rather than 20200506. Same thing happens when the email gets created.

Please let me know if you need me to provide more info.

Thanks a lot for your help!!!


Hi @alfonso,
Make sure you are using this expression : Now.ToString(“yyyyMMdd”)
Find below screenshot for your reference.

Hi @chandan.kumar,

Sorry about the late response, I hadn’t been able to get back in until now.

Does this mean I can’t use the options straight up? I believe the guy in the video did, that’s why I was wondering if I was choosing the wrong one or something like that.


For problem 2: you need to open Project Notebook and change the formula from sheet Date cell B9. The default value is =TEXT(Date;“YYYYMMDD”) however this works only when you are using English.

Hi Mircea:

Thanks for your reply.

What would I need to change the format to? This is what it currently looks like

Thanks and cheers,

I guess that the value in B9 is “YYYY0506” so what you need to do is to replace "=TEXT(Date_Input,“YYYYMMDD”) with something that works on your region. Since I don’t know your regional settings I cannot tell you the exact format.

I got what you meant and I was able to solve it. Let me share it with you, it might help other users…

My Office is installed in English, but my regional settings are for Mexico (where I live), so the Project Notebook is using YYYY (for Year) rather than the letter for “Year” in Spanish (which is A), so once I changed YYYYMMDD to AAAAMMDD (the letters for Month and Day are the same in both languages), everything worked as expected.

Thanks a lot, I really appreciate your help.