Filter Data table weird issue

I’m trying to remove row that contain no value in the cell.
Read range give a var:DTvar > Filter data table (DTvar=DTvar) (Remove row, column name = “” ) > write range back to the worksheet.

the rows of the empty cell has removed but it created duplicate row at the end of row. For example it remove 10 row that contain no value and it will create 10 duplicate row from the last 10 row.
I did troubleshooting and see the result step by step in the workflow, narrow down to this filter data table and write range

is it a bug? Or something i did wrongly? I did try remove duplicate rows but it doesn’t work, any expert can show me how it work?

Hi @Anneng

Do you already tried use it setup like this:


(In Filter Data Table Activity)

Yes, i tried too.

Weird, I did and it work properly.

You can try to use Remove Empty Rows activity from the Autossential.Activities package:



If you still have issue, share your excel workbook to we try it out.

I solved the problem. I read range lock at certain range to get the exact value and filter remove row is working now.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.