File UiStudio.settings can't be found

I installed UIpath community edition and created simple flowchart.
When I press Run (F5) I get the error:

[ERROR] [UiPath.Workflow.Logging.StudioTraceListener] [4] System.IO.FileNotFoundException: Could not find file ‘C:\Users\xxx\AppData\Local\UiPath\UiStudio.settings’.

But the file exists. For some reason UIpath is not able to access it. Seems like a rights problem, but I have got admin rights.

Any idea?

I’m facing the same problem. Please help. I have uninstalled and reinstalled a couple of times and yet it fails to work.

Put ur activity inside try catch actvity

Hello,

Please add “UiStudio.settings” under path “C:\Users\user\AppData\Local\UiPath\UiPath”.

Its need to present under below given both the path.

C:\Users\user\AppData\Local\UiPath\UiPath and
C:\Users\user\AppData\Local\UiPath

Please add and run again, it works.

Thank You

Hello,

Please add “UiStudio.settings” file under path “C:\Users\user\AppData\Local\UiPath\UiPath”.

Its need to present under below given both the path.

C:\Users\user\AppData\Local\UiPath\UiPath and
C:\Users\user\AppData\Local\UiPath

Please add and run again, it works.

Thank You

1 Like

I’m also facing this issue, but I cannot run UiStudio at all.
Following the advice to copy the .settings file to the UiPath\UiPath directory did not help.
Looking at the file contents, it looks like a corrupt xml file.
Running with UiPath 18.1.1

If your facing this problem once you uninstall the uipath and delete uipath folder in %localappdata%
%appdata% %programdata%\ C:\Program Files (x86)\ and clean the temp folder in our system and reinstall uipath.

How to add “UiStudio.settings” in the above mentioned path?

I am having the same issue: “System.IO.FileNotFoundException: Could not find file ‘C:\Users\my.username\AppData\Local\UiPath\UiStudio.settings’.”

The file UiStudio.settings is in the mentioned folder.

I tried the suggestions above, uninstalling and reinstalling UiPath, and also copying the file to C:\Users\user\AppData\Local\UiPath\UiPath and C:\Users\user\AppData\Local\UiPath, but none of the alternatives worked for me.

Having the same issue here. Windows 7, UiPath 2017.16522. Cannot publish due to this error. Any suggestions other than those above to fix this?

I have the same issue, uninstalled and reinstalled and added the UiStudio.settings in the ‘C:\Users\my.username\AppData\Local\UiPath\UiStudio.settings’ but still nothing works. Is there a solution to this? Thank you

19:17:42:826 => [ERROR] [UiPath.Workflow.Logging.StudioTraceListener] [14] System.ServiceModel.FaultException: The system cannot find the file specified

Server stack trace:
at System.ServiceModel.Channels.ServiceChannel.HandleReply(ProxyOperationRuntime operation, ProxyRpc& rpc)
at System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object ins, Object outs, TimeSpan timeout)
at System.ServiceModel.Channels.ServiceChannelProxy.InvokeService(IMethodCallMessage methodCall, ProxyOperationRuntime operation)
at System.ServiceModel.Channels.ServiceChannelProxy.Invoke(IMessage message)

Exception rethrown at [0]:
at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
at UiPath.Models.IUiPathRemoteContract.StartJob(Stream jobInfo)
at UiPath.Models.UiPathProxy.StartJob(JobModel job)
at UiPath.Models.UiPathDuplexProxy.StartJob(JobModel job)
at UiPath.Workflow.Execution.WorkflowRunner.StartJob(JobModel job)
at UiPath.Workflow.Execution.WorkflowRunner.Run(String workflowFilePath, String projectName)
at UiPath.Workflow.ViewModels.MainViewModel.RunWorkflow()
at UiPath.Workflow.ViewModels.MainViewModel.<get_RunWorkflowCommand>b__72_0(Object param)
at UiPath.Workflow.RelayCommand.Execute(Object parameter)

Is this issue resolved .I am still facing the issue tried all the suggested way.

Hello,

I am also facing the same issue… I tried copying settings file in both the path… but still showing same error… Please help. I am just trying my first program to enter a name and show a message box.

Prem Thakkar

Hello,

It worked now :slightly_smiling_face: :
Thanks
Prem

Hi Prem2179,

I am facing the same issue.Please give reply how you resolved the issue.

Thanks
Satheesh

My bet would be on any protection software blocking the access to the folder.

My main issue is after installed UIPath community edition on win 7 64 bit laptop, its working fine.Once I shut down my laptop and once again login into my laptop then my UIPath studio is not working(process is not running).From last 3 days onwards Iam unstalling and installing Uipath to work with studio.I know that It is not good idea but time being I am doing .Please give any permanent solution.
My error is
There was no endpoint listening at net.pipe://localhost/UiPath/service/duplex/agent/DELL that could accept the message. This is often caused by an incorrect address or SOAP action. See InnerException, if present, for more details.

Hi @satheesh_kumar

This solution might work for you:

Hi @loginerror

Its working fine now.Thanks for your support.

Thanks
Satheesh

1 Like