File properties missing using PowerShell

Hello there,
I need to get number of slides from PPT file and after merge two presentations to new one.
I using powershell script to load file properties but it can’t load relevant data. It load only date modified, attributes, name, data accessed, item type, size and data created values. Full properties info should be much more values.
If I try to run powershell script from windows powershell it loaded without problems. This happend only when I call powershell script from UiPath Studio by UiPath.Script.Activities.PowerShell.RunPowerShellScript and on our server solution. On community edition studio v2019.6 with same Office 2007 all works great.

Environment:
OS Windows 10 v1809
UiPath Studio 2019.4.3 Enterprise Edition Windows Installer
Microsoft Office Standard 2007 v12.0.6425.1000

Get-FileMetaData PowerShell script
https://gallery.technet.microsoft.com/scriptcenter/Get-FileMetaData-3a7ddea7

Perhaps its a permissions issue? Are you running as admin when you do it locally?

Also do you get the same result when you use “Invoke Power Shell”?

It’s same result and my local user is administrator.

Edit: When I run project with studio launched under administrator (run as administrator) result is same.

Bump!

Hey, sorry for the delay. Does the issue only occur when run on a server? Does the script being called by UiPath workon the local machine?

Yes, issue only occur when run on a server UiPath Studio v2019.4.3 When I run script on server manually from powershell it’s OK and from UiPath Studion on local machine too.

Everything works after Office Service Pack 3 installed

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.