#FeatureBlog - 19.4 - SOAP and Swagger (based REST services for Library projects)

Thanks. It worked for me. The Orchestrator URL of cloud is
https://platform.uipath.com/[AccountName]/[ServiceName]/swagger/docs/V2

2 Likes

please help
I have tried https://platform.uipath.com/[My Logical Account Name]/[My Service Name]/swagger/ui/index#/

I got my Logical Account Name from https://docs.uipath.com/cloudplatform/docs/managing-account-settings Site URL I also tried the name because why not

and the service name I got by looking at my services in https://platform.uipath.com/portal_/serviceinstances

what am I doing wrong? it keeps giving me “The document is invalid”

is there anything I need to do first?

I have downloaded and run https://forum.uipath.com/uploads/short-url/iZsjSYaXMTLLC10NKW2wkVVbUus.zip

but I do not know what I should do with my key,

any help will be greatly appreciated,

thanks,

Kevin

Hi @Kevin_Riley

Actually, you will want to use id_token to discover both logical names, as seen here:
https://docs.uipath.com/orchestrator/v2019/reference#section-discovering-uipath-account-and-service-instance-identifiers


2 Likes

@loginerror thanks for the advice:
I managed to get my AccountlogicalName,
and my serviceInstanceLogicalName but I am not sure what to do now.

I tried adding it with my serviceUrl/accountLogicalName/serviceInstanceLogicalName/swagger/docs/v2
but it just give me the same error message.

is there anyway to debug it or an instruction manual somewhere?

I am attempting to follow along with the UiPath 2019.4 Updates.

any advice?

thanks for your time,

Kevin

Hi @LoginError,

I am creating a similar webservices library. How to authenticate the user via windows authentication ?

It throws an error when I use the GetQueueItems activity from service library that, authentication has failed.

I don’t want to write / pass the credentials in plain text format, May I know how to achieve this ?

Thanks
VJ

2 Likes

Hi Maciej
I have a problem at the first step when setting variables for authLoginModel: authLoginModel.TenancyName

Message appears:
"RemoteException wrapping System.InvalidOperationException: Can not assign ‘in_TenantName’ to ‘authLoginModel.TenancyName’. —> RemoteException wrapping System.NullReferenceException: Cannot create an L-value from the given expression with property ‘TenancyName’ because the target object is null.

  • at System.Activities.ExpressionUtilities.PropertyLocationFactory`1.PropertyLocation.set_Value (T value)*
  • at System.Activities.Location`1.ReferenceLocation.set_Value (T value)*
  • at System.Activities.Location`1.set_ValueCore (Object value)*
    […] "

Even if I enter any name for ‘TenantName’, it cannot be assigned.

Do you have any suggestions?
UiPath Studio 2019.10.1

Service configured with a link for API from:
https://xxxxxx.ad.intra/swagger/ui/index#/

Hi,

how do we put the username and password if we are using the window credentials ? I am unable to pass the authenticate stage. any advice appreciated.

following the same questions :slight_smile:

Hi,
I found my mistake. I did not enter the Default value for ‘authLoginModel’ value: New UiPathOrchestratorAPI.LoginModel

After entering the data, the process works.

1 Like

Hi, in my process I changed the filtering in the GetReleases activity with:

"Name eq '" + in_ProcessName + "_" + in_EnvironmentName + "'"
to
"ProcessKey eq '" + in_ProcessName + "'"

Works.
If someone has one environment, it will be a good option.

Great topic.

I am trying to use the “GetUsers” call, and it works lige advertised.

But how can I get informatin regarding Org. Units? I can get string values, no problem, but how do i get array values?

I’m trying with this assign, but that does not work:

getUserReponse.Value(0).OrganizationUnits(0).tostring

Any help?

Hello

I have tried this out with SuperOffice SOAP APIs, and it works great. One of my APIs, however, gets an attachment. Is there a way of downloading it and saving it to a directory?
I am able to save it to a Sytem.Byte variable.

Any help is much appreciated.

Hey there,

I want to create a library out of an wsdl definiton.

When I to load it Studio shows all endpoints but when I want to create Activities out of it the wizards shows up an error:

I think that the definition from this webservice is voilating the https://www.w3.org/TR/soap12/ standard.
I asume it because log from studio clearly says that some subservices didn´t exist:
15:29:27.0823 => [ERROR] [UiPath.Studio.exe] [12] Could not find code for operation NetzbetreiberpruefungGetListeMeineNetzbetreiberpruefungen from client Netzbetreiberpruefung with GetListeMeineNetzbetreiberpruefungen and SOAP.

Is there any way to ignore these violations besides to not import them into the library?

Logs from studio are attached. Service related stuff begins at 15:29:27.0823
2020-02-26_Studio.txt (30.4 KB)

Cheers,
Lunk

It would seem that it works if you uncheck this batch of not-working endpoints:
image

I suppose one way to figure it out would be to try to compare how does this batch differ in the definition from the other ones that are working.

The error message is quite straightforward, but if you do believe that these definitions should be correctly recognized, please submit your feedback via the Studio feedback feature with additional attachments (maybe the definition file itself).
Our team will have an extra look then :slight_smile:

2 Likes

Hey @loginerror,

alright, I will submit a feedback post.

Meanwhile I have to use SOAP Request activity for the functions inside “Netzbetreiberpruefung”.

Thanks alot,

Lunk

Hi @loginerror,
Great article, I have done the same in one of implementations where we are consuming a soap service. We provide one input (“pathid”) to the method in order to receive the response. While it works well when we are providing the correct input. But in case, the input is not valid it gives the following error message “GetPathRecords: Could not invoke client method.”. It also provides the same message when the endpoint is down.

Therefore, what should be done to determine the exact cause in case of error flow since we are getting the same message?

When we run the same in SOAP UI, we do get “no records found” in case of incorrect input but that is not happening when we are consuming it through the created library. Any pointers on this would be helpful.

Regards,
Raghav Bidani

@Forum_Staff any idea about this?

Hi @raghavbidani

This feels like a bug. Could you maybe provide a definition file for this service (can be via a PM here on Forum)?
Together with your Studio version.

Also, if you are an Enterprise customer, do not hesitate to report it via our Technical Support here:
https://www.uipath.com/company/contact-us/contact-technical-support

Hi @loginerror,

Sorry for the delay in response. I was able to resolve it later. I was able to extract the correct error message from the inner exception parameter. Is that how UiPath is supposed to read it from definition file because in SOAP UI we do get correct response.

Regards,
Raghav Bidani

Regards,
Raghav Bidani