Faulted Job in Orchestrator when published from Community 2019.7

Hi,

I am experiencing a problem since my Community Studio have updated to the version 2019.7. Any minor modifications I make to a Project, once uploaded to the orchestrator will make it fail with the state marked as “Faulted”. In order to verify if something was wrong with my code I downloaded the latest working package from the Orchestrator [which was published from 2019.6], re-uploaded it and discovered that it still shows as “Faulted” when trying to run it.

After some investigation, I have noticed that since updating to 2019.7 the .json file drastically changes at the moment of publishing. See pictures below to understand the difference, most noticeable one, the schema changes from 3.2 to 4.0. I have tried to change back the schema manually and re-publish, but at the moment of publishing it gets again upgraded to 4.0.

Could you advise in what to do in order to make the newer version of studio behave as it was previously? Please let me know if I can provide any further information and thanks in advance.

Best Regards,

Published 2019.6


Published 2019.7

Orchestrator Error

Hi @dvpg1992,
Is this workflow working for both versions when running from studio?

Hi @Pablito,

I have just run the working version downloaded from the Orchestrator with schema 3.2 - no issues encountered. Afterward I published it and re-downloaded it (schema now changed to 4.0) - this also run with no problem in my local pc with studio. No faulted message appears in any of them, however the second one keeps getting faulted in the orchestrator.

Br,

Try this:

  1. Remove project.json file (make a backup somewhere)
  2. Open project in Studio from main.xaml.
  3. Download every package which is needed in the project.
  4. Make sure that all packages are in the newest possible versions.
  5. Save it. New json file will be generated.
  6. Export this to Orchestrator and try.

Hi again @Pablito and thanks for helping out,

I have tried to do as you said, first anomaly that I encountered was that few activities from GetAppCredentials were missing (standard activities from the REFramework). Because of that it failed validation and couldn’t publish it. So I proceeded in re-creating the activities, saved, published and it still fault in the orchestrator. See below “GetAppCredentials”, new .json and job details from the orchestrator.

GetAppCredentials


.json

Job Details Orchestrator
image

Those errors in studio are because of missing packages. When you are removing json file all dependencies are gone. That’s why I wrote :

You don’t need to recreate them. You just need to re-download the package used for this activity.

Hi @Pablito,

I did follow your instruction and re-downloaded all the packages. However, even after downloading the packages those 3 activities were missing in the flow “GetAppCredentials”. On the other hand they were present in the activities pane and by looking at another REFramework I was able to fix them. Still “faulted” once publishing :frowning:

To follow up -> to download the packages I go via “Manage Packages” -> “All Packages” -> select all the missing one and press “Install” -> “Save” /// Am I doing it right?

Yes that’s correct :slight_smile:
I compared your packages from latest screen with those from the very first. Seems that all packages are installed. And you said that there are some error activities still. This might be the reason why workflow was not working in Orchestrator. Seems that something is damaged in the project. Quite strange thing :confused: I know that it’s easy to say but only thing I have in my mind is to create completely new workflow and based on the old one just recreate everything from scratch.

Hi @Pablito,

what I don’t get is why if I have a version running in the orchestrator and I download it and make edits to that the project suddenly it stop working. Even if I don’t make any changes at all it stops working when re-published. Thing is that the project is quite big and re-create it would take so much time. :frowning:

Hi @Pablito.

I have done another testing and create a simple workflow that just write a line and tried to run it from the orchestrator. Again the project get marked with status “Faulted”. At this point, I do not think is an orchetrator issue but again the studio installed in my machine, which I already tried to reinstall - shall I try a clean install again? See picture belows:

Project


Job Details
image

Hmmm it seems like Studio is damaged indeed. Try reinstall it based on this topic:

Hi again @Pablito ,

I did a clean install following the guide, tried to re-publish again with a simple write line activity and still get the “Faulted” message. I am running out of ideas.

Br,

Do you use CE Orchestrator or your own? If your own, which version is it?

My own, Version 2019.4.3

Hmmm based on compatibility matrix all should work. Anyway I think in that case it will be better to ask here for help (as you have Orchestrator License):

Alright,

thanks a lot for your help and patience.

Have a great day.

1 Like

If you will get it solved, please write here an update. I’m curious as well.