Fails in unattended mode but executes manually from Robot - How To

orchestrator
#1

Steps to capture the resolution of developer window and apply it to the Robot Settings file or Orchestrator runtime.

Troubleshooting steps

please make sure the proper resolution setting has been defined i.e. height, width & depth

The below snapshot shows the configuration done in one of the machines for the Robot to execute in unattended mode with a specific resolution. The resolution is taken from the dev environment where workflow was developed and applied on the Robot machine in UAT/ PROD environment.

How To - Setting up Resolution # :

Development machine from the studio:

  1. In the development server:
  • Use the “Take Screenshot” activity. Using this activity, do not select anything on the screen, select the entire desktop.
  • Use “Save Image” activity to save the image at the desired location.
  1. Check the details tab in the properties of the image saved. Note the depth, height, and width.
    Once you have all the details, Login to Orchestrator and change the Runtime settings(Resolution Width, Height and Depth) for the Robot which is running as mentioned in below screenshot -
    Robot machine:

  2. Login to the robot machine.

  3. Open uipath folder under program data. Add in UIPath.settings(path : %programdata%\UiPath\UiPath.settings) file the height depth and width that you have noted in the appropriate parameters. Logintoconsole: false (small f)

  4. Restart uipath robot services (Run -> services.msc -> Uipath Robot -> Restart)

  5. Reboot the machine.

  6. Logoff from the system.

Once you follow the above steps then check if you are able to run the job from Orchestrator in unattended mode and share the outcome.

Note:
Make sure to logoff/Sign off from the Robot machine rather than disconnecting.

closed #2