Failing to capture text from formula bar

excel

#1

Hi,
I have 2 issues that I am currently struggling with. I am working in a edit protected workbook

  1. I am trying to select a particular cell , say F11 , using select Range - done
  2. using send hotkeys, I am trying to navigate to the next cell above using “up” - works
  3. when i try to select the cell to the right of F11 using HotKey “right” , - fails , left, and down work

Issue 2

  1. select the cell F11 as above - done
  2. select the cell above F11 using “up” - done
  3. Using Get text, Get full text, get visible text to get the cell name from the formula bar “E11” - comes up blank when i display the value using message box
  4. Using Get google OCR text , I was able to get the text displayed “E11” but when i run the program the second time , it throws an error
    “message”:"Get OCR text ‘Edit’ : Cannot find the UI element corresponding to this selector: <wnd aaname=‘Name Box’ omit:cls=‘Edit’
  5. when i use “Attach to live element” , it works another time, to fail the next time. Just to add, this is also happening when the workbook is not protected.
  6. I have also tried to deselect one of the identifiers individually in the selector, but to no avail.

I know my question may have been lengthy. In case i need to elaborate more, please let me know. I may not be able to paste snapshots due to upload restrictions.

Thanks :v: