Facing issue while triggering bot from Local machine's Orchestrator to execute it in AWS machine

Bot is developed in Local machine studio (CE)
AWS machine has licensed robot in it.

I have provisioned AWS licensed BOT with Orchestrator (CE) in my local machine.
Now when run the job in my local machine, to execute the bot in AWS RDP, it fails with this message:

Quick help would be appreciated.

Executor start process failed, reason System.UnauthorizedAccessException: Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))
at UiPath.UiSystemClass.OpenInteractiveWindowsSession(String bstrUser, String bstrPassword, UiOpenSessionFlags nFlags, String bstrApplication, String bstrAppArguments, Int32 nDelayMs, Int32 userToken, UiGenericOptions options)
at UiPath.Core.Setup.OpenInteractiveWindowsSession(String username, String password, OpenSessionFlags flags, String application, String arguments, Int32 userToken, Int32 preferredWidth, Int32 preferredHeight, Int32 preferredDepth, Boolean fontSmoothing)
at UiPath.Service.Impl.Executor.StartProcessInSession(Guid executorInstanceId, String username, String password, SettingsDictionary execSettings, IntPtr userToken)
at UiPath.Service.Impl.Executor.<>c__DisplayClass17_1.<b__0>d.MoveNext()

Hi @Mallika

Could you see this topic? It should give you an idea:

Thanks, Yes i went through the post by Pavan:
Hey guys, Even I had the same issue initially. I fixed for myself. Sharing my experience so that if any one of you have the same issue then will fix an isssue for you guys too.

Reason for my issue: I did not had password set for my windows system and same I did not provide in UiPath Orchestrator robot section.

Hence, Solved by setting up a password to my windows system and updated the same in UiPath Orchestrator robot section. After successfully setting password it worked flawlessly.

Hope it could help some.

Thanks,
Pavan

But how do i create user password settings in (AWS) remote desktop?

My case is : I trigger the bot from my local machine orchestrator to execute the bot in the remote desktop(AWS)

I have done Provisioning of the Robot agent in AWS with Orchestrator in my Local machine, and then run the job from Orchestrator.

1 Like

Another point I would like to inform is:

I have developed the bot in Uipath Studio CE (18.4.1) while the AWS has Uipath licensed version 18.2.3.

Can that be a problem? If yes, how do i upgrade the version of the licensed Uipath studio and robot in AWS(remote desktop)?

1 Like

We use UiPath (Orchestrator and Robots) in AWS and don’t have any issue with this. During my setup, I did run through various scenarios to generate errors so I could document them for myself.

As the other thread indicates, you want to check the credentials associated with the Robot in Orchestrator are valid and match the user that you wish the robot to log in as on the Robot host machine.

We have our EC2 instances joined to our on-prem domain, and leverage process accounts for our robots. Are you trying to use the default administrator / password generated by AWS when the EC2 is provisioned or have you created a local user account for the robot?

Here I detail , what excatly I am trying to do:

  1. Robot Host Machine is the AWS, the Remote Desktop. Licensed UiPath [Enterprise Edition (Robot) 18.2.3] installed in AWS.
    image

  2. Bot developed in Local Machine UiPath Studio [Community Edition 2018.4.1 ].

  3. Orchestrator [UiPath Community Edition 2018.4.1] setup done in local machine provisioned with AWS Hosted Robot.

  4. Credentials provided to provision Local Machine Orchestrator with ASW Robot : user: admin, and password left blank.

Please suggest where am I getting wrong.

If the ADMIN user you have set in Orchestrator for the Robot is indeed blank, I’m not sure if UiPath supports that or if it might be a restriction of Windows as UiPath login via console mode by default / on the admin account.

I would suggest setting a password and updating your Robot record in Orchestrator.

In my testing

  • Create local account (robobob) on EC2 (Windows Server 2016)
  • Create Machine (AABBCC) record in Orchestrator
  • Create Robot record in Orchestrator (With valid username/password for local account in the format or <username> e.g. robobob or AABBCC\robobob. using local\robobob / localhost\robobob while valid UiPath does not seem to accept it)

I’m able to successfully run a job without issue. I’ve provided no other special permissions to the local other then it is part of the local “Users” group on the machine.

In order to further validate it, I added robobob to the local Remote Desktop Users group and allow simultaneous sessions so I could RDP in as the robot and watch the work being performed.

image

image

Thanks for the reply.
Do u see any issue with the version mismatch?
Robot Machine is of version 18.2.3 while bot developed in Studio 18.4.1 and Bot triggered from Orchestrator is 18.4.1

According to the Robot compatibility page, Orchestrator 2018.4 is compatible with Robot 2017.1 and newer.

ok, so it clearly mentions that
Studio and Robot always need to have the same version.

My studio was 18.4.1 nd robot is 18.2.3.
This could be the issue

Thanks for sharing the document
I will try to upgrade the Robot version and then re execute.

I take that to mean if Studio and Ui Robot service resides on the same host, they they need to be the same version or further down there is an impotent notice which seems like it is speaking to major versions 2018 vs 2017 and not the minor 2018.3 vs 2018.4.

I currently develop with Studio 2018.4.x and deploy to Orchestrator / Robot 2018.3.x.

@ovi @loginerror can you clarify the backwards compatibility?

My Orchestrator is also 18.4.1 in Local.
While Robot is in 18.2.3 in RDP