Extracted workflow

I have aa extracted workflow (Invoke AddtoDictionary).
When i fill it to my main workflow it doesnt work. But when i take the data from this workflow and paste straight without extracting - it works.
Whats the problem here might be?
Thanks.

image

Hi @Slavich!
Did you check your arguments in Main when did that invoke?

Cheers!

1 Like

Hi @Slavich

Check the invoke workflow activity for arguments. Based on what you mentioned, it looks like your input/ output arguments are not set properly. Click on import arguments and set it for the first time. Next, to check go to the collection property and check whether it’s set properly

1 Like

It seems I have set arguments (picture 1). Here is argument dict. What more should be done?
Could you clarify, please?
Thanks

On your ’ Invoke workflow file’ you have button ‘import arguments’, you must click on that and provide dictionary variable in your Main, because you have dictionary varible in extracted workflow with direction ‘out’

1 Like


I entered to import arguments in my “inwoke flow” and tried to choose different types of dictionary (iDictionary, KeyValuePair). But in main flow it still doesnt get the argument.
Error-Object reference not set to an instance of an object…

So basicly, what is an idea…you don’t have to change those first three columns because those are informations from your extracted workflow file. You only need to make Dictionary <string,string> with same name in youn Main and pass that variable name in column ‘value’

I am sorry I tried, it really not clear to me. :no_mouth:
From the very beginning. I have a ready- filled Dictionary<String,String>. How should I use it as a workflow to get and then use data from it?
Maybe I did smth wrong from the beginning…

Main.xaml (6.6 KB) VariableIN.xaml (4.1 KB) variableOUT.xaml (4.0 KB)

Hey @Slavich no problem!
I just created simple process for you where you can see both directions. Please find annotations and just do the same with your dictionary and that’s it.

Hope this hepls! :smiley:

1 Like

Got it. Thank you.
But when I implement it in my workflow it


recieves error - (see screenshot).
If i start playing with types of argument I get the errors before compilation.

Please take a look on this link: https://www.youtube.com/watch?v=fO-c5-e4yUE
This is tut for passing arguments, maybe this will help.

1 Like

It clarified me how extracted processes work. But didn’t help in my case, sorry. The problem is - the arguments types.
I think I’d rather insert the sequence as it it s without extraction to workflow. Thats the only way it works.
Anyway thank you for help.