Extension issue in unattended bot

Hi guys

Am trying to automate a silverlight application . I have installed silverlight developer version and extension and everything works fine in development environment when I try to move it to production in a unattended robot environment it’s giving me a selector error on silverlight in production environment I have installed extension and it’s reflecting in registry settings any idea what else can cause this ?

May I know what was the exact error that’s coming in log
This can be resolved buddy
We need to check with the selector whether they are made in such a way that it can handle even in unattended way
Cheers @roshanmk007

Hi @roshanmk007 - Open UiPath in admin mode then install Silver Light extension.

May be the silverlight extension got corrupted. you can reinstall or try once in prod

Cheers @roshanmk007

Actually when I try to schedule the workflow from development it’s working fine while moving into production all this is happening. To ensure that I took an another development server and tried installing silverlight extension from setupextensions along with silverlight developer even xaml is working over there also but production server is not having studio just an unattended bot is available.

Is there any difference in adding extension for unattended bot ?

1 Like

Studio is not there in production server

Fine
Did we try reinstalling the silverlight extension again in the production instance
Cheers @roshanmk007

You can use install Silverlight using cmd as well here is the link .

Multiple times I tried installing and checked in registry in order to verify installation is successful. I tried re installing silverlight developer edition also

@roshanmk007
It could be a resolution issue. Is the screen resolution same in case of Dev and Prod?

If you are using Orchestrator to run the Bot, you could change the resolution in Orch to match with that of Dev screen.