"Explorer.exe" Lesson 2 Act 1

Lesson 2 Activity 1:

Hello everyone, whenever i try to “indicate on screen” the Notepad, it selects me the “explorer.exe”.

I’ve tried a lot of things and i cannot find the solution, by the way im really new to this, maybe im making a rookie mistake.
Thanks everyone for your time.

Tomas Padilla

Hi @Padilla_Tomas

Give notepad.exe instead of explorer.exe


Welcome to Uipath Community @Padilla_Tomas,

Please check the selector whether it’s pointing notepad.exe, or change it to <wnd app='notepad.exe' cls='Notepad' title='*Notepad' />


Still isn’t working, i have a Spanish Windows Language, it may be that. But anyway i can’t find a way to make it work.

Thanks anyway!

I found a way:

Instead of selecting the ICON on the windows bar i selected the OPENED WINDOW of Notepad.

Now it opens a new notepad for each answer (True or False on the flow decision )Selection

Hope this can help anyone else too. We still need to find a way to select the icon and not the opened app.

Thanks all,
Tomas Padilla


Yeah, this is the proper way to select the application.

1 Like

Hi @Padilla_Tomas,

When you want to work on an application there are 2 option for that:

  1. Open application Activity
    You always have to indicate screen to robot can detect how application look like(or you should show it where it will look into with selector variable).


  1. Start Process Activity

You can start application with this activity. After that if you want to work with this you should define it again with Attached Window Activity if you keep working on it. This is different from open application.


If you use Start Process Activity, the application will be open until using kill process activity.
If you use Open Application Activity, the application will be closed after activities are done on it.