Execute Macro: Exception has been thrown by the target of an invocation

getting below error while using Execute Macro from Access.
Execute Macro: Exception has been thrown by the target of an invocation.

Attaching my file and screenshot of the simple code.
I have added the imports as well.

image Database1.zip (17.0 KB)

Tagging @balupad14 who will be the right person to assist with this.


Hi @testing_mail

Have you given the path correct in studio X


yes, that’s the path.

@balupad14 will help you out with this!

1 Like

Hi @testing_mail

Unfortunately I can not able to upload the package due to the UiPath Go! Revamp . You can get the latest package here.

Thank you

I am getting this error and I did not find in this thread what resolved it. Please help. I am very new to UiPath. Thank you for your help in advance.

The error generally means a paramater value doesnt exist or is incorrect - in this case it could have been the filepath or macro name etc.

If you provide more details, I would be happy to assist.

I was not able to attach because I am a new user. However, I did double check the path. I selected the … (lookup) to find the path to the database. I double checked the macro and I even by passed/eliminated all the prompts since my macro is updating tables.

I noticed the version of the BalaReva.Access.Activity in my UiPath is 2.0.2. Could that be the problem? When I test the test file attached at the top of this thread it does not work either. I get the same error.

How can I update my version of the package to the 2.0.3 in case that is the issue?

Thank you again.

Download the nupkg listed above, you will the need to copy that package into your local package folder, that can be found in manage packages then goto settings.

Hello, I was able to update the package to the most current version (attached to this thread). I am still getting the same error. I also downloaded the sample in this thread and it also fails with the same error.