Exception while reading CSV for salesforce automation

csv
activities
salesforce

#1

Hi everyone , i am trying to do salesforce automation by watching the video tutorial for salesforce automation on uipath i am getting Argument exception while running for each row module in the flow chart , below are the flow charts please do help!!





#2

Hi Sandeep,
There are two chances of error.
1)May be you are not using same datatable which is getting from Read CSV activity.
2)There can be space after Name i.e "Last Name " in CSV File.

If this not help you,Please share the Read CSV properties Screenshot.


#3

Thanx Uday i checked the for the points you have mentioned but that is not the case i think, the problem is coming inside for each row i think because i tried reading the same csv and write that csv to another csv and it is working the data is getting copied to another csv, but showing error when using for each row for salesforce automation , looking forward to hering from you.

I have Changed the location of the csv directly to the project folder so please dont get confuse as above pics are having different location of csv .


#4

Hi Sandeep,

Can you please check the Datatable name mentioned FOR EACH row as Image shows “Contacts” however Output of Read CSV shows “dtContacts”. Request you to please get both in sink with naming.

Once done please check. It should work.


#6

Hi Uday you were right ,i corrected my CSV file for space now the problem is solved ,Thanx alot


#7

Hi,
Did you try with the newer version of “salesforce”. I have a problem - When the “New Account” link clicked - the automation stops and giving the following error,

Type into ‘INPUT 58:1951;a’ : Cannot find the UI element corresponding to this selector:
SalesforceAutomationSample execution ended in: 00:00:56

This is where the “New Account” Popup needs to come. Please help to solve. I am stuck here.

Thanks…


#8

Hi,
I’m just starting with UiPath and having a similar problem. I have taken the Salesforce tutorial as an example. I have a csv-file and a for each loop but I’m getting a similar error as mentioned above. The complete message:

Main has thrown an exception

Message: Column ‘Polisnummer’ does not belong to table .

Source: Type into ‘Polisnummer’

Exception Type: ArgumentException

System.ArgumentException: Column ‘Polisnummer’ does not belong to table .
at UiPath.Core.Activities.ScopeActivity.OnFaulted(NativeActivityFaultContext faultContext, Exception propagatedException, ActivityInstance propagatedFrom)
at System.Activities.Runtime.FaultCallbackWrapper.Invoke(NativeActivityFaultContext faultContext, Exception propagatedException, ActivityInstance propagatedFrom)
at System.Activities.Runtime.FaultCallbackWrapper.FaultWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)

I have checked for spaces and table names but that seems to be fine. Does anybody know what could be the problem? Below a screenshot:


#9

When you read your csv file into UiPath and into your datatable have you selected Add Headers or First Row Contains Headers? Double check your csv file to ensure the file contains that exact title. Otherwise - do a loop through the columns within the datatable…

For each column.name in Datatable.Columns
log column.name
Next


Help Beginning of UIpath
#10

Hi Richard, thanks for the help! Problem solved!


#11

Hello guys,

I have the same error like you before. But I checked for all thinks that are written here and the error still occurs.
So I hope you can help. Otherwise my computer will be thrown out of the window;).

Regards and thank you for your help
Sebastian


#12


#13


#14

The error here is quite clear. The column IBAN does not exist in your datatable. Check the name of the column in your file it may contain spaces around it or be called something else. Alternatively you may not have added headers rows to your data table.

Richard


#16

Hello All,

just to add something that has not been mentioned in the responses above, you may get an error if you have the wrong deliminator, please note its either a comma or semicolon depending on your csv file

image