Exception caught at sending SMTP Email: 5.7.1 Unable to relay

Hi, I am having error sending SMTP email via robot and the exception message that I receive is as below

Exception caught at sending SMTP Email: 5.7.1 Unable to relay

I researched and it seems like it is due to authentication level but the email address has worked in other environment.

Hi @inyourgravity,
Have you tried to use different package version? Are there any differences between environments?

The mail activities package used is 1.1.6562.21018
There is no differences that we are aware of, but we’re looking into it.

1 Like

Have you found a solution. I’m having the same issue.

MailKit.Net.Smtp.SmtpCommandException: 5.7.1 Unable to relay
at UiPath.Mail.Activities.SendMailActivity.EndExecute(AsyncCodeActivityContext context, IAsyncResult result)
at System.Activities.AsyncCodeActivity.System.Activities.IAsyncCodeActivity.FinishExecution(AsyncCodeActivityContext context, IAsyncResult result)
at System.Activities.AsyncCodeActivity.CompleteAsyncCodeActivityData.CompleteAsyncCodeActivityWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)

It seemed like our client’s IT did not add robot’s email address into the relay list. After it was added, the issue was solved.


Our hosting partner had not set up everything for my new robot machine. Messages from its IP were not allowed through the SMTP server.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.