Excel Write Cell not working as expected


I’m trying to extract data from a software under Citrix environment to an Excel file.
For that I’m using the clipboard to exchange data from Citrix to local machine (ctrl+c on the citrix application and Get From Clipboard activity to retrieve the data).

The data are well copied in the clipboard.
And if I do the “ctrl+v” manually in an Excel file I have the expected data :slight_smile:

But when I use the Excel Write Cell activity it dump the name of the worksheet but not the data…

I tried with the Write Cell activity :

And the Write Cell Activity from the Excel Extension package :

Both activity gave the same result :

The expected extracted data should be something like that :

The data are well copied, I dumped the variable content into the Output (using Write Line activity) and the output is correct. So the problem is limited to the Excel Write Cell.

Data extracted are tab separated. Is the Write Cell activity support that ?

Any idea about this kind of problem ?
Using another package could solve this problem ?

Thanks !

Buddy try without mentioning the range in write cell just “”

That would work buddy


What is in your Data variable? Can you show the assign statement?

If I set the Range to empty I’ve nothing dumped in the file.


Here is my test :

The Data variable (String) contain the right data :

I Tried to set the Data variable to GenericData, no more luck, but now, with String format, I’ve something in the Excel file !
But not correct, all the Tab characters are removed from the string… So all the text appear in on cell only…

Is it ok to open the excel file and paste the data directly? So instead of Get From Clipboard activity. Open excel file and paste using Ctrl + v.