Excel workflow

What does this error mean? I used the Write Range activity for workbook and ran my file.
Source: Write Range Message: Object reference not set to an instance of an object. Exception Type: System.NullReferenceException RemoteException wrapping System.NullReferenceException: Object reference not set to an instance of an object.

Some data maybe null values

If possible can u share the screenshot ? @Asha_Desai

Regards

Nived N :robot:

I got to work but the first three columns gets reapeated. Why?

Hi @Asha_Desai

Issue why the column is repeating is since u are asking to write in write range from D1 cell that is why it is writing entire again from D1 cell

Regards

Nived N :robot:

Happy Automation :slight_smile: :slight_smile:

Thanks Nived! You were very helpful. I didn’t catch that error. Sorry I am completely new to IT with healthcare background and trying to learn this on my own, so learning the basics is a huge task for me.

@NIVED_NAMBIAR…do you think you can explain to me how I can get Uipath to respond to Excel application? I have been using workbook right now.

regards,

Asha

Ya sure @Asha_Desai

Write range will write the datatable completely

In ur case u are reading a datatable and writing to an Excel file

So.what u need is since u had put write from cell as D1 it will start writing the entire datatable from D1 cell that is why u get it as related

So instead of D1 put the write from cell as A1

it will works

Mark it as a solution if the above works for you

Regards,

Nived N :robot:

Happy Automation :slight_smile: :slight_smile:

Thanks…that worked and I now understand. But can you tell me why I cannot use Excel Scope application to respond to Uipath? Anytime I use Excel scope activity and workflow is runs but no changes made in my Excel and it doesn’t even open Excel.

Hi @Asha_Desai

U means while using excel application scope u are not getting the same result as the above

Also u are saying that excel application scope doesn’t open the excel while exceution

If that so , check visible option in excel application scope properties panel if it is unchecked

Regards

Nived N :robot:

Happy Automation :slight_smile: :slight_smile::slight_smile:

Regards

Thank you. yes the excel does not open. I did check the visible option and no matter what I do it doesn’t work. The only thing that I noticed is under Manage Packages, I do not see the Uipath.Core.Activities installed. I searched it to install but it does not show up. Would that cause excel application to not respond?

Hi @Asha_Desai, i am not clarified with your query
can u elaborate it please?

thanks…i got it to work

Can I tell how it worked? @Asha_Desai

I had to go to Manage Packages and add the activity package for excel…than it worked.

1 Like

:+1::+1::+1::+1: