Excel: Text to columns stopped working, need alternative method

My ribbon has greyed out as inactive. The automation has worked just fine until now. I’m looking for another way to do the “text to columns” in my sheet.
Mind this:

  • The Excel file is not saved, and it shall not be saved. (GDPR)
  • The file looks like a CSV, but it is actually a TAB seperated one (CST?)
  • As said, it worked as clockwork before, this problem just recently happend. As shown in the picture, the ribbon turns greyed out. (The Office programs updated?)
  • It is the “same file” every time, it is an outcome of a report in Oracle eBusiness Suite
  • The problem is not 100 percent happening, rarely it works. I’ve trid with different Delays and Element exists, but this does not cut it.
  • In the video-link (0:48) I am visualizing the problem, showing two methods that previously worked, me using the first one.
  • My problem is not grouped sheets.

In the first method in the video, I am using only “Send Hotkey”. No problem before. Now, the ribbon greys out, and destroys the process :-/

Additional information currently:
MS Office pro plus 2010
MS Excel ver. 14.0.7237.5000 (32-bit)
UiPath Studio 2019.11.0-beta.2

Anyone knows a solution for this?

hi @bjorn2390

first use read range and then use build data table activity and create columns and then use write range


Thank you, @AshwinS2. I’ve now tried your suggestion. Not successful: My Excel sheet is not saved, as stated above. How can I read outside/without Excel scope? (Excel scope requires path, right. Any alternative?)

Is this greyed out when opening excel file manually
If so we need to check with the application
Or we can validate here in our UiPath
Cheers @bjorn2390

Hello, @Palaniyappan. When opening the Excel file manually, this is not happening. It only happens during automation. Thank you.

1 Like

did we try with START PROCESS activity where pass the file path of excel file as input to filepath property
and then we can use the SEND HOTKEYS activity for text to column conversion
Cheers @bjorn2390

Still not working. It seems to have trouble with the marking of A-column. When A-column is marked (Hotkey CTRL+" "), the ribbon is greyed out (the DATA-section of the ribbon).

Hello again.
I’m sorry: Did you mean that it worked for you with this solution @Palaniyappan ?

no buddy, i didnt simulate this
but that would work, moreover in your video it seems like they have either used the hot keys…
i didnt here the voice…but i was able to see hot keys been used
Cheers @bjorn2390

Would you be so kind to try my process when you have a moment, @Palaniyappan.
I would appreciate it very much, thank you.
Looking forward to your feedback.
Excel_text_to_columns1.zip (23.8 KB)