Excel Scope - Open took 10 mins

In ‘excel application scope’ , it will take almost 10mins to finish this step. Reason might be the Excel file is too large, is there any way to reduce the open time? Please be noticed, my Excel have several worksheets, also format. so datatable may not be a great way to solve right?

Hi @pitaty - Do you really need to open the Excel or is that fine to perform the steps in the back end. If you do not need to open excel then uncheck the visible property.


i tried uncheck visible property, but it still took a long time

Any macro enabled worksheet? Or the size of the workbook is huge? If you do not require the excel to open then take off the Excel Application Scope and use normal Excel Activities. This is just a suggestion, if you would like to try.


yes, it’s huge, 3000K+
i need to read from excel, is that ok not use ‘excel application scope’?

You can use the system provided read range activity without using the Excel application Scope.