Excel read range problem

Hey everyone,

i am facing a problem with the Read Range acitivity… It always starts reading at row 4 but i dont know why…

I selected “Add Headers” and wrote into Range “A1”

Any ideas what to do? Why isn’t he starting at row 2

kindly mention the range as “” simply without any cell position
Cheers @NiclasW

Yes, i tried it too… But then it is the same :confused:

hmm
–use excel application scope and pass the file path of excel
–inside the scope use READ RANGE activity and mention the range as “” and the sheetname from where we want to extract and enable the add headers property
–this would work for sure buddy

Cheers @NiclasW

When i output my first variable of the sheet in a message box then it pop ups the number 4 instead of 1

I think its the same way like mine…

hmm if possible can i have that excel with sample data (not the original data) so that i can come up with a solution for that
Cheers @NiclasW

I think i solved the problem myself… It is because the activity loops through each row and after that my customer number etc. is empty because it gives me the result of the last row :slight_smile: i filled in some data for the empty rows and now it is working.

Thanks @Palaniyappan for your help !!!

aah
i was wondering like why it didnt
so what we mentioned with range as “” and sheetname and addheaders enabled were all right
so the data unavailability made this
Cheeers @NiclasW