Excel opens as read only, how do I write to it?

Hi, I am very new at UiPath, and have no one at work to ask.
I am to get information from an excel file, use this information in a Sharepoint Environment, and then I am to write some new information to the excel file. I have managed to get the data from excel using the Excel Application Scope, and manage to use the information in Sharepoint. However, the excelfile opens as a read only document, and I do not know how to make it writable so that I can write back to it. Any suggestions?
I have also tried the Start process and managed to make the excel document writable. But then when I wanted to use the Read Cell activity it says I have to open it via the Excel Application Scope. I do not want to use the Read Cell from the Workbook, as I have to enter the workbook path to every cell I want to read, and there are quite a few cells.
In short, I want to open excel, read information from a few cells. With this information I am to do some things in Sharepoint, and when this is done, I want to write back to excel that the Sharepoint work has been done. Or if I got an error, I want to write back to excel that the Sharepointwork did not work.

can you check if that excel file is not in read only mode:
right click on file> choose properties> on bottom if ready-only is checked then uncheck it > click ok and we are good to go
else make sure worksheet is not password protected

The excel is in a Sharepoint library. All documents are Read-only when opended from this library. But it seems to work if I use the Click function and click on the Edit workbook button, Before I use Read Cell or Write Cell. I hope this works going forward as well. So I might have managed so solve it myself. :slight_smile:

1 Like

how did you solve this issue?

Disable the Excel Read only for all excels by changing the preferences. This will help you reduce your code and will help open the file as editable in every single iteration. Refer below article for reference:

Hi @ahaegglund,

I tried using click function but it does not seem to work. Any additional configurations you did?

Thanks!!!

Hi, I try to avoid excel if possible. I have had several cases when the excel document gets blank after the robot has been there working. Everything gone. I do not know why. But I did not do anything else but the Click activity. Perhaps you can try as Jagdish2593 suggested, to disable Read Only for all excels.
Kind regards,
Anna

I have the same problem now
I make sure I disabled read only for all Excels but some times when robot try to open excel file or creates a new one the process stopped with this error

“File C:\Users\m.Bakr\Desktop\test\Meals Counting Raw Data.xlsx is read only and can not be overwritten. It has been saved as file C:\Users\m.Bakr\Desktop\test\Meals Counting Raw Data(1).xlsx”

any help please??

1 Like

I have the same issue please help to bypass the readonly popup with “no” as answer

Did you get any solution for this issue?

Hi, No, I did not get a solution, but I managed to solve it by using the Click function and click on the Edit workbook button, Before I use Read Cell or Write Cell.

1 Like

Ok Thank you

We upgraded Office 2013 to Office 365 and suddenly Excel Application Scope with documents stored in Sharepoint 2013 stopped working with an error ‘is read only and can not be overwritten. It has been saved as file [*]’. One solution, as you mentioned (thank you), is to set ‘Excel Application Scope’ as visible with a ‘Click’ activity, and the other is with using a ‘Write Range’ activity without ‘Excel Application Scope’. After that writing was successful.