Excel in SharePoint Throws Exception HRESULT:0x800AC472

Hi All / @loginerror

I have an issue where I keep getting ‘HRESULT:0x800AC472’ error at ‘Excel Application Scope’ Activity. The excel I am accessing is located in SharePoint and previously, it had always been working well till recently I upgraded my Microsoft Office 365. The error message can be seen here.

In addition, is this a SharePoint issue? Once I bring the file out of SharePoint (i.e. on my desktop), the issue does not happen and works seamlessly.

Could someone help me on how to solve this issue please?

Thanks in advance,

Jack

Hi @robot_learner

Could you provide a dummy example version of the path that you use to get to the file?

Also, does this help here?


(using workbook Read Range activity rather than the Excel Application Scope one)

1 Like

Hi @loginerror

Thanks for the reply. Here is an example of the path to get the excel -

C:\Users<UserID>\SharePoint2019<FolderName>\myexcel.xlsx

The most wried part is that at times, it works but at times it throws the ‘HRESULT:0x800AC472’ error. I had tried to place a kill process activity for EXCEL before the excel application scope but it does not seem to work >.<

Meanwhile I will also look up that solution which you provided.

Thanks!!!

1 Like

What is the size of the file?

Could you also make sure you are running the latest Excel activity package?

Hi @loginerror

I tried the solution you shared which @dgreen used, and it seems to work. I no longer have the error ‘HRESULT: 0x800AC472’ occurring once I removed the ‘Excel Application Scope’ activity. Thanks @loginerror, @dgreen :slight_smile:

May I know why ‘Excel Application Scope’ activity throws the error ‘HRESULT: 0x800AC472’ intermittently when the EXCEL 365 is placed in SharePoint? I am curious to know why.

Thanks for the help! it is greatly appreciated!

Regards,
Jack

This is a good question!

Could you maybe provide some more information about your environment? Studio version, Excel activity package version? (please also try the latest preview version first to see if the issue wasn’t fixed already).

Hi @loginerror

My Studio version is v2018.4.5.
The Excel activity I am using is v2.5.1 I am unable to get the latest excel package due to security restrictions in my side.

Thanks!

Regards,
Jack

Thanks, I registered an issue. Our team will look into that.

It would still help if you could provide the full error message in the Forum post (simply copy paste). It will help us to narrow down the issue.

Hi @loginerror

Thanks so much for registering this issue up! I have extracted the error message here and looking forward to see what caused this issue. Thanks!!

18.4.5+Branch.support/v2018.4.Sha.2a53a262e2c1098055c3ecbdabe73d45e0a6dc29

Source: Excel Application Scope

Message: Exception from HRESULT: 0x800AC472

Exception Type: UiPath.Excel.ExcelException

An ExceptionDetail, likely created by IncludeExceptionDetailInFaults=true, whose value is:
UiPath.Excel.ExcelException: Exception from HRESULT: 0x800AC472 ----> System.Runtime.InteropServices.COMException: Exception from HRESULT: 0x800AC472
   at Microsoft.Office.Interop.Excel.ApplicationClass.set_Visible(Boolean RHS)
   at UiPath.Excel.WorkbookApplication.Initialize(WorkbookArguments args)
   --- End of inner ExceptionDetail stack trace ---
   at UiPath.Excel.WorkbookApplication.Initialize(WorkbookArguments args)
   at UiPath.Excel.WorkbookApplication.Initialize(Application excelApp, WorkbookArguments args)
   at UiPath.Excel.Activities.ExcelApplicationScope.Execute(NativeActivityContext context)
   at System.Activities.NativeActivity.InternalExecute(ActivityInstance instance, ActivityExecutor executor, BookmarkManager bookmarkManager)
   at System.Activities.ActivityInstance.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)
   at System.Activities.Runtime.ActivityExecutor.ExecuteActivityWorkItem.ExecuteBody(ActivityExecutor executor, BookmarkManager bookmarkManager, Location resultLocation)

Thanks!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.