Excel "HRESULT E_FAIL has been returned from a call to a COM component" when selecting a target on a filter for UI interaction in Excel


I have a process which makes frequent use of clicking options on a filter list on Excel. It uses ‘click’ and ‘check/uncheck’ UI interaction activities and has worked perfectly until recently, where now when I attempt to edit the target to fix the selector, it gives the error: “HRESULT E_FAIL has been returned from a call to a COM component”.

I’ve searched around and another similar topic on this was left unanswered. One workaround given for this error appearing (on a browser) was to use ‘keyboard shortcut’ activities to Tab through elements and press Enter instead of a ‘click’ activity. But I don’t really have that option as the filter lists used in my process are usually too large to reasonably tab through and are variable, so it would be far too complicated to translate that into a variable number of tab presses that would change every run of the process. It feels especially unnecessary to go to the lengths of implementing such a convoluted workaround when it was working perfectly not too long ago (which makes me think this is more likely a bug with Studio that has been recently introduced).

It’s not a case of my device being the problem either, the same error occurred with the published process when an unattended bot tried to run it (which, again, worked perfectly a few weeks ago)

If anyone has any advice or is able to look into this problem, it would be very much appreciated.


Hi @jkelly32,

These COM component issues are a pain, they are pretty much generic errors thrown by different applications and we don’t know what’s wrong. Ideally, update your UiPath.UIAutomation.Activities package and UiPath.Core.Activities to the latest version (or at least to the version that matches your UiPath Studio).

In most cases you will still have an issue but you’ll notice the description has changed for example a selector is off, or screen out of bounds, etc.

hope this helps.

Hi, thanks for the reply. I could not find UiPath.Core.Activities anywhere in the Manage Packages directory but I updated UiPath.System.Activities and UiPath.UIAutomation.Activities and UiPath.Excel.Activities. Unfortunately, it has not helped fix the issue. I still get the same error. If I use UI Explorer to try and click on the checkmark in the filter window box it states “Could not GetAncestryInfo”

If you have any other ideas to fix this would be very much appreciated. I cannot understand for the life of me why it was fine doing it and now suddenly it cant select it at all, and its the case in any project I or a bot tries to run.

Oh yes, UiPath.System.Activities is the correct one. Sadly, these COM errors are quite generic I can’t tell exactly what might be causing it. Are you able to share a code sample with the problematic actions? Also, can you let me know your uipath version?

On a side note: are you using UiPath enterprise? if so, have you tries raising a ticket to support?

I’m not able to share something specific, it just happens with every instance of Excel and on any UiPath project. If I apply a filter on the data within Excel and click on the dropdown to open the pop-up, the UI is unable to select/deselect any of the values to apply a filter (although it was able to do it previously).

I am currently using Studio 2021.10.4 with an Enterprise License. I will try to raise a ticket with support for it too.