Excel - How to deal with Exception from HRESULT: 0x800A03EC

A few workarounds to the common error code 0x800A03EC.

Before you check it out, please make sure you are running the latest available stable Excel package from our Official feed.

If you have encountered this error during your Excel processing, please make sure:

  • you can access the file your are working on
    (in case of shared drives → the file is not open by another user)
  • the file is not open already open in a non-standard editing mode (read-only, password-protected, etc)
  • there is no conflicting Excel processes running in the background

To solve the issue, one could try to:

  • add a delay between operation on the Excel file (if the issue comes from two actions on the same file in the short amount of time)
  • make sure the Excel process is closed before the Excel Application Scope starts working on a file
    (i.e. by killing all running Excel processes)

Pleas also reference these topics about the issue:
https://forum.uipath.com/search?q=0x800A03EC%20status:solved
(they all contain a post marked as a potential solution)

Let us know if you encounter this issue and it cannot be solved by the above mentioned suggestions.
We would love to know your particular scenario to be able to better address this general issue.

7 Likes

Hi @loginerror,

I am facing this error when using Background Process Template and creating Excel file. I have been using State Machine for the same process and it was working fine. I have recently converted my Project to run in Background using background Process Template and it throws this error.

I have checked, it is the first excel application scope of the project and Excel is not running in the background as well while I run the project.

For your information, i am running this automation on an unattended BOT when this error is occured, however when i run it from studio, it works well.

Could you please suggest possible solutions to this ?

Thanks

Hi,

We had a number of these Excel error codes after an enterprise update from 18.4.3 → 19.10.4. The issue turned out to be with reaching the add-in that came with UiPath Studio X. Add-ins were disabled by our organisation (same way as macros may be disabled), but since there is no option to enable add-ins on excel application scope, this caused an issue. We removed the add-in and everything was back to normal. It is ambigious how Studio X activities, the add-in, activities from the UiPath Team’s Excel Extension Package and the standard UiPath Excel packages are linked. I am not sure why the Studio X add-in affects the Excel Application Scope, I presume it supposed to enhance integration with Excel.

We had another issue that we have previously identified with a simlar code (before the update). It was due to a macro being run by the run macro activity. If we ran the macro manually it worked, if we ran the macro with the run macro acitity we ran out of RAM after a while. Adding Application.ScreenUpdating = False and Application.xlCalculation = Manual solved the issue.

Kind regards,
Balint

Hi @loginerror

I have recently also faced this issue. Could you help me with it please?

To share, my company is currently using v2018.4 Standalone UiPath Studio trial licenses. We had been running this robot which interacts with excel to get some data. It had always been running fine w/o issue. Excel was on Microsoft 365.

However, we recently exported this package to run it on a new machine with Excel 2016. It worked perfectly fine too. The issue came in when Excel was upgraded from 2016 to Microsoft 365. Here onwards, we had begun to intermittently , get error code 0x800A03EC at Excel Application Scope activity.

We are in the progress of trying out the solution you provided such as adding the delay. Was curious, besides the workaround you mentioned above, are there any other workarounds which we can try?

Thanks for the help!

Regards,
Jack

1 Like

Hi @robot_learner

Would you be willing to provide more details about the issue?

Mainly:

  • exact Studio version, including patch number (highest available is 2018.4.6)
  • Excel activity package
    (could you try upgrading it to the highest version too and verifying if this doesn’t fix the issue)
  • details about your process
    (it would help a lot if you could provide a new project that causes the issue with minimum amount of dummy data)

The issue is really hard to catch and we would appreciate any types of reliable reproduction steps :slight_smile:

2 posts were split to a new topic: Excel Application Scope: Exception from HRESULT: 0x800A01A8

Hello @loginerror @Balint.Kulcsar

I am getting error: Create Pivot Table: Exception from HRESULT: 0x800A03EC

I am using two Use Excel activities from StudioX to create Pivot Table. First one runs fine on the second one I get the above error. I have tried writing it to the same sheet as well as different sheet of the same excel file.

I have used closed workbook and delay work around without success.

When I kill excel before the second Use Excel activity I get a little different error:
" RPC Server not available".

I am using Community Edition Studio Version: 2021 2.0 beta44.

Is there anything else I could try?

Thanks

Hi @Haroon_Patel

Which Excel version are you currently using?

I am using Excel Version 2102 (Build 13801.20294).

I am using studioX activity Create Pivot Table. I have used this activity twice. I get this error on the second one, first one runs fine and it creates the pivot table.

Could you maybe provide some screenshots of how your process is configured?
What is your version of the Excel activity package?

Per @loginerror the first thing to try is open package manager and verify which version of the UiPath.Excel.Activities the project is using, then if you are not using the latest -preview version, please try upgrading to the latest preview version and see it the issue still reproduces.

1 Like

Hi UiPath Team,

Attaching below error:

I have many write range activities with in one Excel Application scope but I am getting this error at last activity.

As suggested, I have tried adding delay of 5 sec between each write range activity but didnt work.
My Excel Activity Package version is 2.10.4.

PS: 1. If I create last write range activity separately from original Excel Application Scope. It is working with this workaround.
2. This workflow was working fine until yesterday.

I would appreciate

I have just seen this error happened to me and realized that the issue was the “Protect Sheet” that I enabled before. I just changed the cell protection to “Unlocked” (just un-check the Locked option) for the data range I was copying and save the Excel file and re-run the bot and issue was fixed.