Excel formulas in local language is not working

excel
activities

#1

Scenario:

Steps to reproduce: Attach a workbook, use “Write Cell” and add a formula in non english. Example in Swedish: “=SUMMA(A1:A10)”

Current Behavior: Excel doesn’t recognize this as a correct formula.

Expected Behavior:

Studio/Robot/Orchestrator Version: 2017.1

Last stable behavior:
Last stable version:
OS Version: Win10
Others if Relevant: (workflow, logs, .net version, service pack, etc):


How to write a formula in csv cell?
#2

Hi @vincera

Does the formula work when you enter it manually?


#3

Yes. And I can put the marker in the formula to edit it and press enter right away and it starts working. I thinks Excel “translates” it somehow, but when doing this through automation, this activity never happens.


#4

Uhm… So if your Excel is in Swedish, i don’t see why it wouldn’t write the cell. What if you would automate with Type into the marker your formula in Swedish? (i cannot test this since my excel is in English)


#5

Seems like UiPath is writing to cells .Formula property. This can be solved by using .LocalFormula property instead - it could be either changed in the activity, or possibly a checkbox InArgument<bool> UseLocalFormula

https://msdn.microsoft.com/en-us/library/office/aa205983(v=office.10).aspx


#6

That’s probably it!


#7

Hi,
I got the same problem with Ukranian language.
I solved it by sending after using Write Cell the hotkey Enter into the formula string like this:


But could you give me more details how to use your solving of this problem?
Thanks!


#8

Hm, it working just if C1 selected, need to add Select Range for C1 firstly


#9

And more one way - writing formulas in English, it works regardless of system language


#10

It wasn’t a solution, just a short guess/investigation why it’s not working currently and a possible way why.

What I wrote would require either writing your own excel integration, or UiPath altering theirs.