Excel formulas in local language is not working

Scenario:

Steps to reproduce: Attach a workbook, use “Write Cell” and add a formula in non english. Example in Swedish: “=SUMMA(A1:A10)”

Current Behavior: Excel doesn’t recognize this as a correct formula.

Expected Behavior:

Studio/Robot/Orchestrator Version: 2017.1

Last stable behavior:
Last stable version:
OS Version: Win10
Others if Relevant: (workflow, logs, .net version, service pack, etc):

1 Like

Hi @vincera

Does the formula work when you enter it manually?

Yes. And I can put the marker in the formula to edit it and press enter right away and it starts working. I thinks Excel “translates” it somehow, but when doing this through automation, this activity never happens.

Uhm… So if your Excel is in Swedish, i don’t see why it wouldn’t write the cell. What if you would automate with Type into the marker your formula in Swedish? (i cannot test this since my excel is in English)

Seems like UiPath is writing to cells .Formula property. This can be solved by using .LocalFormula property instead - it could be either changed in the activity, or possibly a checkbox InArgument<bool> UseLocalFormula

https://msdn.microsoft.com/en-us/library/office/aa205983(v=office.10).aspx

3 Likes

That’s probably it!

Hi,
I got the same problem with Ukranian language.
I solved it by sending after using Write Cell the hotkey Enter into the formula string like this:


But could you give me more details how to use your solving of this problem?
Thanks!

Hm, it working just if C1 selected, need to add Select Range for C1 firstly

And more one way - writing formulas in English, it works regardless of system language

It wasn’t a solution, just a short guess/investigation why it’s not working currently and a possible way why.

What I wrote would require either writing your own excel integration, or UiPath altering theirs.

1 Like

Here’s what we found out, testing a few examples:

Scenario 1:
Excel in German + trying to enter a formula in German: worked for some formulas BUT not all.
Example that didn’t work: “=LINKS(…)”

Scenario 2:
Excel in English + trying to enter the same formula as above now in English (=LEFT(…)): worked.

Scenario 3:
Excel in German + trying to enter the same formula as above again in English (=LEFT(…)): worked.

Our question to UiPath:
Can we be sure that writing the Excel formula in English (in Assign or Config file) and then using Write Cell (even in a File that has language settings to another language, e.g. German) to write it in a cell will work?
What’s going on under the hood?