Excel Data can be updated via Studio but not updated via Assistant (post publish'''0

Hi, I created an application that retrieves data from multiple excel files, computes it and finally pushes this data into a different excel file (name: PnLAvg).

My issue is when I run this application via Studio, the application runs as expected, however when I run this file via Assistant it fails to load this data into PnLAvg.
image

Hi @Saad_Sajjad_Khattak

What kind of error are you facing while running through assistant!

Does the process set to main.xaml while running through assistant?

Regards

The Assistant fails to update computed data to PnLAvg, But Throws no errors.

Also how do I check is the process is set to main.xaml while running throw Assistant.

Thanks

I just checked the entry point is Main

Hi @Saad_Sajjad_Khattak

Does the latest version package is running through assistant?

Regards

Hi @Saad_Sajjad_Khattak

Have a view on the below thread!

Regards

Yes, All Packages are up to date.

Hi @Saad_Sajjad_Khattak

Its strange!

Tagging @codemonkee @Palaniyappan @Yoichi @ppr to have a view on the above!

Regards

Hi,

I think you might use relative path to write excel file.
If we run process via nupkg (Assistant etc), it’s extracted to %USERPROFILE%\.nuget\packages\[PackageName]\[version]\lib\net45
So the excel file which is updated might exists the above place. Can you check there?
Usually it’s better to use absolute path, if run process via nupkg.

Regards,

Hey @Saad_Sajjad_Khattak !!
I think the error is because you are updating the excel inside the package and not in the excel of the machine where the robot is running. Can you review this?

Thanks!!

This is correct Thank You so much, I just moved it to a different location and it worked.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.