Excel Automation with StudioX - Practice - Books Sales Report - Part 1

This course is designed so you can also learn from your fellow learners, particularly through the forum topics.

If you need help with Part One of the Book Sales Report practice, post a question as a reply below. To increase your chances of being helped, be as descriptive as possible. Include in your comment:

  • A description of your issue: when is it happening, what activity you have trouble with.
  • A screenshot of your error.
  • You can also attach your automation project.

If you can help a fellow learner, don’t be afraid to reply and make a suggestion. Participating in the conversation helps solidify the knowledge you’ve acquired in this course.

Good Course

I don’t understand where this formula came from that is used to multiple the list price by the practiced price. How would we ever come up with that creating the automation from scratch.

Saved.Values(Of UiPath.Excel.ExcelValue)(“ListPrice”)*Saved.Values(Of UiPath.Excel.ExcelValue)(“PracticedPrice”)

Good course

Yeah it confused me for a bit since it wasn’t working, but all i had to do was add an “equal” “=” sign and then variable1variable2
so,
=variable1
variable2

1 Like

Hi, when I write cell using the variables ListPrice and PracticedPrice, I have the below error:
Conversion from string “List Price” to type ‘Double’ is not valid. Input string was not in a correct format
I don’t understand where it comes from.
thanks

Hello
I am completing this exercise as part of the Citizen Developer Foundation course. I can’t get the multiplication formula to work. I have the exact same action as in the solution - write cell, what to write: ListPrice*PracticedPrice, where to write: [CurrentRow] Price. When I run the provided solution it multiplies the values, but when I run what I developed it write the 2 values with * in between, without doing the multiplication. I have spent so much time trying different options and can’t get it right. I wish the solutions explained in more detail what has been done. Most of the comments above seem to be referring to writing the full code, anyone just using the interface that can help?
image

1 Like

Hello!

I have just been doing this practice, but I am encountering a strange error. So for the activity “for each excel row”, and even though I check “Has headers”, the plus icon does not show me the title and the price.

It comes up only when I change the range to a sheet like Week 7 or Week 8. It does not come up for the “current sheet” selection. How do I fix this?

I have also attached the screenshots for better understanding.

Thanks in advance!

Hi,

You’re on the right track. For Value to lookup, select ‘Current Row > Custom Input’ then type ‘Title’ for ‘Column Name.’ You’ll need to use the same methodology a few more times below.

1 Like

What you’re doing here is writing the expression in text, so the output is a string.
You filling out the field “What to write”, you want to select “number” rather than “text”, then it will actually do the math instead of writing out a string!

=variable1 variable2 solution worked!!

thank you!

This right here worked for me.

Did not work for me. I mean it started to write some correct products, then it stopped after the first and gave me this.

► The data you want to write “=18.460.95” has a wrong format; ► Excel is busy or you are currently editing a cell; ► If your data is a formula, make sure you use comma as parameters separator; ► During the write operation make sure no dialog windows are opened.

I had the same issue as getting a string result with ‘var1*var2’ as my variables of type ‘Object’ were used in a string context when I input them directly into the text editor. And I do not have the ‘number’ editor choice.
So what worked for me was to have an explicit conversion by using the following formula to get a numerical result:
Convert.ToDouble(Price)*Convert.ToDouble(Practiced)
Using the advanced editor to enter it.
Hope this can help others.

1 Like

Great course my day to day tlife will never be the same!

hello david may ask if the final assessment of this course also doesnt show up to you ? i am trying to answer it but it crashes on me. Do you have the same problem?

Hello shahad sorry for the delay, I have already completed the Citizen Developer program, as far as I can remember I had all the exams. I will double check and get back to you.

Shahad it did work for me , do you have a screenshot?

Great! This is a great workaround