Excel Automation with StudioX - Books Sales Report

Getting error for replacement of £ with nothing as "*Something went wrong with an Action .
Activity Modify Text ( Modify Text ) failed:

Value cannot be null. Parameter name: Source text should not be null.*
Please help me out

1 Like

At Modify Text, after removing Pound, I had saved it to price column (then it was saved as string). I was wondering how I can change the data type from string to number.

I bypassed by saving it to saved value first and then used Write Cell but I would like to know if there is any command to covert string to number.

Hi Have you resolved your issue? I am getting the same error and not sure how to fix it

1 Like

And where can I find “…edit the Close option from Properties to Always”. I dont see any Option “Close” in the properties. Thanks

Hi all, by far the trickiest exercise so far. :grimacing:
not the exercise in itself, but while doing it, I had several bugs/troubles linked to recent Updates from UIPath and the Excel Activities packages. Reason i am listing them here is because you might experience the same difficulties.

  • Suddenly I could not refer to a cell in an opened ‘Use Excel’ Activitiy, until i noticed that the UIPath UI Interface in Excel had disappeared( not popping-up like a few days ago, but now hidden in the top menus in Excel).
  • Another problem probably linked to an update was that Tables inside Excel where not all recognised by the Use Excel or For Each Row activities. No solution found except a reload from the local Activity package, as well as deleting the steps that where not working properly.
  • Those problems brought me to complicated solutions with Append Activities and Scratchpad usage… You know, one first doubt oneself, and if it worked ten min ago, why not anymore?
    So I learned something for sure, but i wasn’t done in 30min, far from it.
  • the Table Extraction Tool changed in the middle of my session. That makes one part of the job easier> with the new Tool, selecting a second Column for the Price Extraction, one can save the result as a number, getting rid of the Pounds Character at the same time. Another Step however got more complex, at least for my Workflow. Since I had used the URL Extraction to save every Genre pages along with the Genre itself, and with a for Each Row from that extracted table, navigated from a genre to another, extracting in the process, having to redo steps with a new tool, which was not saving URL in the same way was frustrating.

So all in all, this exercise is a bit too much of a step-up. But as written, mostly because of those tech issues. So if something similar happens to you, stick to it! :wink:

I agree I’m getting more and more lost.

There is literally no data extraction tool available in the UiStudio I was instructed to download, so I could not complete this activity. So frustrating.

Having done a lot - a lot - of Excel work in the past, this robot was a blast to create. I see many uses for it.

Table Extraction tools seemed like a slightly different version then the one in the video demo, my extraction tool seemed to have trouble obtaining the full link path for the authors for the quote/author exercise.

Really enjoyed this exercise - bringing together elements of web, excel and email.
More difficult, but got there in the end.

Just one question: After I run the robot, the Error or Output log pops up and I have to click Dock and/or AutoHide to close it. Is there a quicker way to do this? I’m very lazy :wink:

I am currently having this issue. any idea what I am missing?

I click the title, click next in the wizard and click the price and get the error of “Please indicate fields that are correlated with the fields you indicated to define the first column”

Hi @NatesMom

Would you be able to record a short video of your issue? You could use a simple tool like ScreenToGif :slight_smile:

I figured it out. I was clicking both the price and the title in the first item not first and last. So I would click the price and the title in the same item the first two clicks instead of clicking to add correlated field and doing price for first, price for last, add correlated clicking title for first and title for last.

1 Like

Capture

I hope you specified the source in ‘Text to modify’ field (as shown by the arrow in the picture) from where the text is to be searched and replaced in ‘Find and replace text’ section. I say so because the error says that the source text should not be null (empty).

Hope this helps.

In the properties panel of the ‘Use Application/Browser’ that was created for ‘Extract Table Data’ activity.

Hope this helps.

3 Book names no on the website causes errors. After removing it, got a successful run. Should there be a skip if N/A build into the sequence?

Hi everyone,
I run the table extraction, but the automation does not switch to the next side. In the solution the “next” button is hit without any problem, but I see no difference. Can anyone help?

Thanks!

The Book Sales example was very challenging for me cause i could not get past the excel for each row , i guess at some point i had (has headers ) unchecked and never realized it until the end . but it was a good exercise in automation. looking forward to more

1 Like

There is an issue even in the solution. The bot stops at the step “Modify Text”. I encounter exactly the same issue.

1 Like

Yeap, I think there are too many missing pieces in this exercise that resulted in me taking wayyyyy too long for this assignment. The extraction tool in the video should be updated so that everyone is aware that the number of rows should be “0” so that everything gets extracted.

1 Like