Excel application scope : Type mismatch. (Exception from HRESULT: 0x80020005 (DISP_E_TYPEMISMATCH))

Hai all, am getting the above mentioned error, can I know the the reason for that error.And am using the excel 2007. The below is the xaml file attached.
Main.xaml (7.9 KB)


1 Like

on the second excel activity you are calling for “writeExcel.xlsx” but if you rare using Excel 2007 it probably wants the old suffix "writeExcel.xls`?

Ok, thanks @AlexJank.

hi @AlexJank, given the xls file but getting the same error…

sorry, @sushmithaelluru, I can’t reproduce the error - I actually tried your xaml and it worked fine for me (I have Excel 2016 though)

Your workflow works for me too.

Can you try changing your output workbook to .xls?

Ya worked for me @CBlanchard. Thanks.

Ok @AlexJank. Thanks.

Good to hear :slight_smile:

Hi, I am getting the same error. I am using Excel 2016 though

Do all your excel file types match?

Hi, it’s okay, I figured it out. I had to kill the excel task running behind and try again. Thank you :slight_smile:

Ya ok.Thanks @CBlanchard.

Hello everyone, i have the same issue and i don’t manage to fix it…
I have a big project and its run it until number of transaction is 200 and something. The program read excel files and do some actions for each row.

Its working well until some point, that is not the same, sometimes 217 anothers time 204…

My project is in UiFramework Template so… its hard to upload here…

Please help…

Thank you

Hi @Ionut_Istrate

Could you try to post the project as a zip file? Please remove all sensitive information first.
This would make the debugging easier.

Does the issue happen every time yet randomly on the same exact data set?

Please also include the version of the Studio (CE or EE), version of the activity packages (please try to update those first to the latest version) and the exact, full content of the log message :slight_smile:

1 Like

Thanks loginerror for your response, but i think is because of the Internet Explorer. I need to check some data into some web site and i see that suddenly the internet Close, but the robot continue, and in the Output Panel i dont receive message that the robot is killing the process… So i manage to do it in case o this error to repeat the proces from where left. :slight_smile:

1 Like

Hi @Ionut_Istrate
Can you explain how did you create the repeat process after that error you receive?

For me the prob was using Excel Aplication Scope very close to other Excel Application Scope. I change the last Excel Application Scope with the Write Range, Append Range or Write Cell from the Workbook activities. I hope it will work for you.

1 Like

I had the same issue. It worked, when i use delay, because it seems like when you write in excel, the excel cannot close as fast as the opening and writing into next excel file.

2 posts were split to a new topic: Excel 2010 - Creating Pivot results in Type mismatch. (Exception from HRESULT: 0x80020005 (DISP_E_TYPEMISMATCH)) Type mismatch