Excel application scope to paste T9 tab: Exception from HRESULT: 0x800A03EC

Bot is throwing this exception while opening an excel file in my process.
The process goes like this:-
1)I am opening excel file using ‘Start Process’ activity in order to tackle the popup (Update excel popup) without failure. (If you use excel application scope, it is difficult to handle the popup in the beginning).
2)Once the popup is handled, I am closing (Killing excel process) the file.
3)Once the file is closed, I am opening it again using excel application scope and doing the operations such as read, write on it.

This process worked well without any error but for now I am getting this exception and I checked for any background excel processes are running during this exception but its not.

Kindly help me out!!!

Hi Yogesh,
There could be many reasons for the error , for example if excel license is over . Did you try checking the exact error in event viewer ? Please share the code if you still face the error ,i will try to check .

1 Like

this is because your are using kill process activity, some times it corrupts the excel. Remove it.

You can do the edit links option and try to disable the links that popup while you open the excel using the DATA tab in excel. If you still want to follow the process don’t kill the excel after the start process activity use click to close the pop up and use excel application scope to do the operations as required. it will work.

1 Like


Giving some delay between kill process and excel application will help. Can you try this :slight_smile:

1 Like

Actually I have already used that option to disable the popups. I was not using Kill Process activity initially but sometimes popup handling activity used to stop working so I introduced it later.

Thanks a lot for your suggestion!!

Sure. I have added a delay. But how come the entire process worked without any error for longer period of time and it started giving exception all of a sudden. :frowning:

Can you elaborate a bit please @Yogesh_Tapkir

I was doing testing for almost 2 weeks and the same code worked without an exception.(Delay was not there in between these two activities).But now I have started getting this exception.

Yeah. May be the reason, your files with huge data or there are some issues with the files.

usually the error states that, you interrupted the operation when UiPath is doing something in the same wrokbook @Yogesh_Tapkir

1 Like

Got it!! Thanks a lot :slight_smile: @HareeshMR