Excel application scope. COM Object

Hi team,

I am getting below error:
Excel Application Scope: Unable to cast COM object of type ‘System.__ComObject’ to interface type ‘System.Runtime.InteropServices.ComTypes.IConnectionPointContainer’. This operation failed because the QueryInterface call on the COM component for the interface with IID ‘{B196B284-BAB4-101A-B69C-00AA00341D07}’ failed due to the following error: The requested object does not exist. (Exception from HRESULT: 0x80010114).

Tried many different things but not able to find solution.

Please advise.


Does this always occurs? Is there any condition?
If possible, can you share your workflow?


No, till now workflow was working fine.
But today it’s giving error for every process in which I have used excel application scope it’s giving this error on that machine. Is there something with excel application on that machine that we should do?


There might be zombie process of excel. For now, can you try to kill all excel process from Task Manger before run workflow OR reboot your machine?



Check below post for your reference

Hope this will help you


Hi ,

I have tried all things mentioned in that post but it’s still not working.

Any other suggestions?

Thanks, I have got the solution and it was the Add-in issue in excel on that machine. I disabled all COM Add-in in excel and rerun the robot it worked.

1 Like