Excel activities deleting image and showing formulas

Hi all,

Currently im trying to create a automation for excel documents
these are the following steps the excel workbook needs to go through

Step 1 & 2 a.b.c are done, However when i try to write formulas with the “write cel” activity it doesnt give me text.
also with deleting a image im having difficulty. I can delete rows but it doenst delete the image.
this is how the excel workbook looks

Does anyone know how to get the formulas to work and how to delete a image

Hi Athevan,

as I understand your requirement, you need to make dynamic directory and place excels after executing operations
if yes then, please follow these steps:
1> create variables like current Month, current Date, Department, Standard Reporting, support etc
2> Get the values for above variables
3> do activities( you can do it by Execute macro activity)
3>use create Directory with assigning full path of directory
4> place the file in the directory
hope this will help,


For image deletion from excel I use the following VB code invoke.
It however deletes ALL images.
The in_argument is the value returned by activity “Excel Application Scope”
You need to add Microsoft.Office.Interop.Excel into Imports.

in_argument objXLS as UiPath.Excel.WorkbookApplication

Dim objWorkbook As microsoft.Office.Interop.Excel.Workbook
objWorkbook = objXLS.CurrentWorkbook

For Each ws As Worksheet In objWorkbook.Sheets
 For Each sh As microsoft.Office.Interop.Excel.Shape In ws.Shapes
 Next sh
Next ws


Sample code for image deletion attached.
.sandbox.zip (8.5 KB)

Apply workaround described here: HOWTO: Use MS Office COM interop with UiPath


I get a error when i try this “no Compiled code to run error BC30456: 'CurrentWorkbook is not a member of ‘Uipath.Excel.WorkbookApplication’. At line 3” do you know the solution to this

Discussed here: Issue Excel library, what am I missing? ".CurrentWorkbook.FullName" not a member of UiPath.Excel.WorkbookApplication - #11 by Victor_Popescu

Install the latest UiPath.Excel activities pack.


I still have the same issue however your example doesn’t show this error.
I have updated all packeges

i didnt add the assign activiy but even with the assign acctivity i get the same error

Try what proposed in the linked discussion - remove UiPath.Excel package and install it again.
The example works fine at my side :frowning:

I know your example also works on my side but when i try to add it in to my workflow i get this error. ill try to uninstal en install excel activities

Still no luck i stil have the same error

The error is gone i deleted the activity and posted it again
but now i get this error

Check if this HOWTO: Use MS Office COM interop with UiPath will help you.


Im also getting compiler error when im using this code…all packages are up to date

let me know if you have any solution

attaching error screen shot

Did you follow the HowTo?